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Application Maintenance Overview 
You can customize the system to meet your company's needs for different applications—anything from 
setting up each user with a unique application interface to linking your company terminals and printers to 
each other and the host system.  

Use application maintenance programs to define the dates your business is closed, to maintain current 
area codes for all of your entities and contacts, and to create musical tunes that alert users to system 
messages. You can also customize the application so that all menus, screens, and order entry views help 
your users to attain high-level performance.  

Use the following application maintenance programs to tailor the system to meet your company's unique 
requirements: 

Program Use to... 
Terminal Setup define the interface between your company's terminals and the host 

system. 

User Maintenance assign each user in your company a user ID, as well as application 
access and authorization. 

Printer System define printers to use with the system, assign printers to terminals, 
assign forms to each printer, and define formats for all forms. 

Custom Menus set up menus to meet your company's and users' needs. Tailor 
standard menus by creating custom menus. 

User Defined Functions define subroutines and formats for printing labels, importing text files, 
and creating custom screens. 

Order Entry Views 
Maintenance 

create order entry views for users and assign those and standard order 
entry views to users. 

Customer/Vendor Standard 
Notes 

define standard shipping and internal notes for sales, purchasing, and 
transfer order transactions. 

Business Closed Days define the days that you are closed for business, such as  holidays and 
weekends. 

Area Code Updating maintain all entity and contact area codes. 

Music Composer compose unique tunes to use to alert users when they have received a 
message. 
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Setup Requirements for User Maintenance 
Following are the control maintenance records and authorization keys for User Maintenance.  

Control Maintenance Records 
Set the following control maintenance records: 

• Enable User ID Prompt For Password Authentication 

• Number of Passwords To Be Saved Before They Can Be Reused 

• Seconds Of Inactivity Before Requiring Relog 

• Tune/Song To Play At Logon 

• Valid Message Group Types 

• Valid Palm Buy Line Product Download 

• Valid Palm Price Line Product Download 

Authorization Keys 
Assign the following authorization keys: 

• AUTH.PWD.MAINT 

• MESSAGE.GROUP.TYPES 

• USER.BRANCH.MAINT 

• USER.KEY.MAINT 

• USER.MAINT.ALLOWED 

• USER.PASSWORD.EDIT 

• USER.TERR.MAINT 

• USER.VIEW.SELECT 

Note: All of these authorization keys are required to access and edit user records. 
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Terminal Setup Overview 
The system administrator needs to define defaults for all terminals, or computers, connected to the host 
system. These defaults define the interface between the terminal and the system. For example, you can 
define a port ID for a terminal. The port ID determines how the terminal connects to the host system and 
identifies the printers to use as its slave printers. The printers and terminal are connected to the same port. 
Terminal settings also affect printer defaults for a particular computer. 

Eterm, the terminal emulator, can be installed and used on terminals supported by DOS or workstations 
running Windows.  

For more information, see Setting up Terminals. 
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Setting Up Terminals 
Use Terminal Setup to define the defaults that terminals, or computers, use when running Eterm, the 
terminal emulator software. When users enter transactions from a terminal, the system uses the defaults 
for that terminal. 

For example, if a terminal's defined pricing branch is Br 1, when a user enters a transaction on that 
terminal, the system applies Br 1 pricing to the transaction. Users can override defaults, as needed. 

After you set up terminal defaults for a user, you must log that user out of Eterm and then back on for the 
terminal defaults to take effect. You must also assign the port ID to the user's terminal from Eterm's 
Configure menu. If you do not assign the port ID, the terminal defaults do not take effect. 

Use the following tasks to: 

• Set up terminals. 

• Apply terminal defaults to a user. 

To set up terminals: 

1. From the System > System Files menu, select Terminal Setup to display the Terminal Setup 
window. 

2. Do one of the following to find the terminal ID you want to set up: 

• Right-click, select Search, and enter the terminal ID. 

• Click the ID column header to sort the terminals alphabetically. 

3. In the ID column, select on one of the following: 

• A terminal ID for which to set up defaults.  

• The blank line at the bottom of the window. Type an ID to identify a new terminal ID. The 
terminal ID is also the port ID. This ID identifies the port the terminal uses to connect to the 
host system. 

Note: This field is case-sensitive. 

4. In the Price Branch column, enter the default pricing branch that the system should assign to 
sales transactions entered from this terminal. If you do not enter a default pricing branch, the 
system prompts the user to specify a pricing branch during order entry. 

5. In the Ship Branch column, enter the default shipping branch that the system should assign to 
sales transactions entered from this terminal. If you do not enter a default shipping branch, the 
system uses the branch entered in the Shipping Branch Override control maintenance record. If 
that record is blank, the system uses the pricing branch. 

Important: If you change the shipping branch on an order and then procure an item, the system 
assigns the shipping branch entered here to the procurement transaction. 

6. In the Printer Location column, select the printer location associated with this terminal ID.  

• If you set a location in the Printer Location column, it is the default printer location for the 
terminal when a user logs on to the terminal, accesses Sales Order Entry or Purchase Order 
Entry, or uses the change location function.  
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• If you leave the Printer Location column blank for a terminal, the system prompts the user at 
log in and when they access order entry to select a location.  

• If a physical branch is defined for the location using the Physical Branch column, when you 
search, the list displays the locations within the physical branch first. Press F10 again to 
display a list of all locations you are authorized to use in User Maintenance. 

7. If this is a modem or hand-held terminal, in the Type column, enter one of the following: 

• RF Term - The port is for a hand-held radio frequency terminal used in a warehouse for 
picking and putting away a product. 

• Modem - The port is for a modem connection used for dialing into your system.  

Note: A user must have Remote Logon OK set in User Maintenance to use this port to 
log on to the system.  

8. Use the following columns to further define your terminal: 

Column Description 
ReLog If this is a counter terminal, in the  column indicate whether to allow employees to 

create orders at a counter terminal under someone else's login name.  
• Yes - Logs the user completely off the system each time they complete a sales 

order with a Pick Up Now status, selects File > Next Item, or uses Ctrl . (period) 
to start a new order. The next user must enter a user name and a password to 
access the system. If an order is still open and displayed in the Sales Order Entry 
window, the system does not log the user off.  

In addition, if you set the ReLog column to Yes, the system requires the user to 
enter their user name and password to log in after the terminal is inactive for the 
time specified in the Seconds Of Inactivity Before Requiring Relog control 
maintenance record.  
• No -The system does not log users off each time they complete a sales order. 
• Lock - Locks the terminal after the user completes a sales order with a Pick Up 

Now status, selects File > Next Item, or uses Ctrl . (period) to start a new order. 
The user is still logged in to the system, and all the windows that were open 
remain open. However, the user must enter their password to regain access to 
Solar. The advantage to setting this field to Lock is that the user can start working 
from where they left off when the terminal was locked.  

In addition, if you set the ReLog column to Lock, the system requires the user to 
enter their password to access the system after the terminal is inactive for the time 
specified in the Seconds Of Inactivity Before Requiring Relog control 
maintenance record. 
You can lock a terminal at anytime by selecting Lock Solar from the File menu. 

Sales Source Select the primary sales department, such as counter sales, inside sales, or outside 
sales, that will use this terminal. If left blank, the system prompts the user to choose 
a sales source at order entry. 

Ship Via Select the default method for transferring products ordered from this terminal to the 
customer. For example, a counter terminal may use Pickup as the default ship via. 

Important: If a customer does not have a default ship via assigned in Customer 
Maintenance and you leave this field blank, the system prompts the order taker at 
this terminal to enter a ship via for the customer's order. 
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Column Description 
Physical 
Branch 

Enter the branch at which the terminal is physically located. 

Local Storage 
Br 

Enter the branch at which images are saved by default. 

9. Save your changes and exit the window. 

To apply terminal defaults to a user: 

1. After setting up a terminal's defaults on the Terminal Setup window, log the user off the system.  

2. From the Eterm > Configure menu select Communications to display the Configure 
Communications screen. 

3. In the ID field, enter the port ID assigned to the user's terminal for which you are applying the 
terminal settings.  

4. Click OK.  

5. Log the user back into the system to apply the terminal defaults to the user.  
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Setting Terminals to Require Passwords After Inactivity or 
Pick Up Now Orders 
For terminals that multiple people have access to, such as at your sales counter or in your warehouse, you 
can set the terminal to require a password to access the system on that terminal under the following 
circumstances: 

• After the time set in the Seconds Of Inactivity Before Requiring Relog control maintenance 
record has passed with no activity at the terminal. 

• After completing an order with a Pick Up Now status. 

Setting a terminal to require a password prevents employees from using the terminal under someone else's 
login name, and also allows faster access to the application because the application is still running. When 
the user returns to the terminal and enters their password, the system returns them to the window they 
were in. 

For example, set individual terminals to lock access to windows each time a sales order with a Pick Up 
Now status is completed, giving the employee an opportunity to walk away from the terminal to gather 
the items for the customer standing at the counter. 

You can lock a terminal at anytime by selecting Lock Solar from the File menu. 

To set a terminal to require a password after inactivity or pick up now orders: 

1. From the System > System Files menu, select Terminal Setup to display the Terminal Setup 
window. 

2. Do one of the following to find the terminal ID for which you want to set password requirements: 

• Right click, select Search, and enter the terminal ID. 

• Click the ID column header to sort the terminals alphabetically. 

3. In the ReLog column for the terminal, indicate whether to allow employees to create orders at a 
counter terminal under someone else's login name. 

• Yes - Logs the user completely off the system each time they complete a sales order with a 
Pick Up Now status, selects File > Next Item, or uses Ctrl . (period) to start a new order. The 
next user must enter a user name and a password to access the system. If an order is still open 
and displayed in the Sales Order Entry window, the system does not log the user off.  

In addition, if you set the ReLog column to Yes, the system requires the user to enter their 
user name and password to log in after the terminal is inactive for the time specified in the 
Seconds Of Inactivity Before Requiring Relogcontrol maintenance record.  

• No -The system does not log users off each time they complete a sales order. 

• Lock - Locks the terminal after the user completes a sales order with a Pick Up Now status, 
selects File > Next Item, or uses Ctrl . (period) to start a new order. The user is still logged in 
to the system, and all the windows that were open remain open. However, the user must enter 
their password to regain access to Solar. The advantage to setting this field to Lock is that the 
user can start working from where they left off when the terminal was locked.  
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In addition, if you set the ReLog column to Lock, the system requires the user to enter 
their password to access the system after the terminal is inactive for the time specified in 
the Seconds Of Inactivity Before Requiring Relog control maintenance record. 

You can lock a terminal at anytime by selecting Lock Solar from the File menu. 

4. Save your changes and exit the window. 

To manually lock a terminal: 

1. From the File menu, select Lock Solar to require a password for Eclipse or any open application. 

The system displays the This Solar Eclipse client has been locked prompt, which indicates 
which user's password is required to access the application. 
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User Maintenance Overview 
The system stores a variety of information about users, such as their: 

• Authorization to perform specific tasks. 

• Order entry views. 

• Individual application setups. 

• Branches to which they have access. 

• Passwords. 

The system administrator assigns an ID and creates a record in User Maintenance for each person who 
uses the system. Authorized users can edit their own records to set user defaults related to their individual 
job functions. Otherwise, the system administrator must set up each record to be unique to the user's job 
functions.  
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User Record Creation Overview 
When the system is installed, it includes one user ID with superuser authority. The system administrator 
can log in using this ID and then create user IDs for all other users. Once the system administrator has set 
up a user's ID, the user should log in and change the password. 

Prototyping 
After a user record has been created in the system, you can create additional user records using the 
prototyping function. This function creates new records with the same settings so that you do not have to 
re-enter the same information for similar users. 

For example, if you create user records for two new employees in accounting, you can define all of the 
parameters for the first user record and then start to create the second user record. You then apply 
parameters from the first user record to the second user record, and edit the fields as needed. 

Virtual Users 
You can also create virtual user records that function like queues. For example, you can create a user ID 
called REQUESTS. Trackers sent to the REQUESTS user ID reside in the job queue for that ID. You can 
then authorize other users to monitor the job queue and to respond to the REQUEST trackers. 
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Creating User Records 
The system administrator is responsible for creating user records, which store information about all 
system users, their authority to perform specific tasks, their individual application setup parameters, and 
their passwords.  

The final step in creating a user record is to assign the user a password.  

The setting in the Enable User ID Prompt For Password Authentication control maintenance record 
determines whether users are required to enter their user ID and password or just their password when 
logging in. 

If users log in using just a password, each user must have a unique password. If you enter a password that 
is already in use, the system displays an invalid password error message and requires you to choose a 
different password. In addition, the system disables the other user's password and notifies them of the 
situation through the message system. The other user also needs to select a new password. 

After you create one user record, you can use the prototyping feature to create additional user records. 

Complete the following tasks to create a user record: 

• Create a user record. 

• Set the user password parameters. 

Creating a User Record 
Enter the parameters that define a user to the system in the User Maintenance window. 

To create a user record: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

Note: You must be assigned the USER.MAINT.ALLOWED authorization key to access 
this window. 

2. From the File menu, select New to display the Enter New User ID prompt, then type the new 
user ID and click OK. 

Note: If you create a user record right after having displayed or created another user 
record, the system prompts you to use the previous user's record as a prototype for 
the new one you are creating. 

3. Complete the fields in the User Information area of the window, as needed. 

Field  Description 
Full Name The user's first and last name. 
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Field  Description 
Root Menu The menu name that determines the system programs to which the user 

should have access. MAIN includes all system menus and is appropriate for 
the highest-level administrative user. To limit the functions available to 
different user groups within your company, create custom menus. 

Note: You must assign a main-level menu as a user's root menu. You cannot 
assign a submenu. 

Nickname  The name by which the user prefers to be called. For example, if the user's 
legal first name is Robert, he may want to be called Bob. 

Title  The user's job title, position, or job function. For example, Purchaser or 
Salesperson. 

Department  The department in which the user works. Click the List button to display the 
valid departments and select one. 

Birthdate  The date the user was born. If you enter a birth date, the Happy Birthday 
message tune plays on the user's birthday. 

Message Tune A short audio tune that plays when the user receives a system message. Click 
the List button and select a tune. 

Sort By How the system sorts the user's full name in lists, searches, and reports. The 
system populates this field. Enter new sort by criteria if needed. 

Commission Plan The plans used to determine how this user's commission is calculated, if 
applicable. If you assign multiple commission plans to this user, *Multi* 
displays in this field. 

Remote Customer If the user ID is for a customer whom you allow to dial into your system to 
view information about their account, enter that customer's name in this 
field. This limits the user's inquiries to data related only to this customer. 

Time Zone The time zone in which this user works. If you leave this field blank, the 
default time zone is that of the server to which the user connects. 
When scheduling events with users in different time zones, such as 
conference calls, the system converts event times to each user's designated 
time zone. 

Note: You can assign some time zones with a generic indicator (MT) or an 
explicit indicator of Daylight Savings Time (MDT) or Standard Time 
(MST).  Regardless of the option you select, the system displays times based 
on the actual state of Daylight Savings or Standard Time.  

Job Functions The job functions this user performs.  

Fax Access Code The code required for this user to access the fax system. 

 

4. Select check boxes in the Options area to define special functions for the user record. 

Option Description 
Salesperson  Identifies the user as a salesperson. The user can be designated as an inside 

or outside salesperson in Customer Maintenance or Sales Order Entry. 
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Option Description 
Enable Break Key Enables user to abnormally end a session using the Ctrl+Break key 

combination. Only the system administrator should have this ability. 

No Logon Prevents the user from logging on. Use this option for virtual User IDs. 

No Messaging Blocks the user from receiving company messaging. Use this option for 
customers who  place remote orders. 

Remote Logon OK Authorizes the user to log in using a modem. 

Picker  Identifies the user as a picker. 

Note: For a user to appear on a picker selection list, you must flag the user 
as a picker and provide access to the shipping branch associated with the 
transaction. 

No Planner Blocks the user from being listed on the Daily Planner or using the 
Scheduler window. Use this option for customer and virtual user IDs. 

Auto UET Message Determines whether the system should send a message to the user whenever 
a transaction the user enters generates an unquality event. Instead of using an 
asterisk, set the value as follows: 
• Blank - Accepts the system default set in the Auto UET Message Display 

control maintenance record. 
• Y - Overrides the system default and has the system send a message. 
• N - Overrides the system default and has the system not send a message. 

Bypass Eclipse Login Enables the user, when logging in, to bypass the Eclipse banner window. 
After the user logs in through the AIX Unix prompts, the application 
displays. 

Credit Manager Identifies the user as a credit manager. Any program that prompts for a 
credit manager will check this field in the user's record. 

No Job Queues Disables the user from being added to new trackers, tracker appends, or as 
the next or last user on a tracker. For example, if an employee leaves your 
company, set this flag to ensure they are not added to future trackers. 

 

5. To set Work Order Entry default views, complete the following fields:  

• Work Order Recall - The default Work Order Entry view for this user when recalling a work 
order. 

• Work Order New - The default Work Order Entry view for this user during work order 
creation. 

6. To set the remaining User Parameters, complete the following fields: 

Field  Description 
Accounts The eclipse database account, which contains all the customer, vendor, 

product, and sales transaction information that this user can access. If your 
company has set up another account for training purposes, you can also 
assign that account to the user.  
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Field  Description 
Locations The printer locations, or groups of printers, accessible to this user. For 

example, if a user works the showroom and counter on different days of the 
week, set up that user for both printer locations. 
Leave this field blank to authorize the user for all printers in all locations. 
Enter the locations in the order in which you want them to appear when the 
system displays a list of printer locations. 
When you log on, the printer location displayed at the bottom of your screen 
is the printer location assigned to your terminal. If no printer location is 
defined for the terminal, the system prompts you to select from the locations 
assigned to your user record. If no printer locations are assigned at the user 
level, the system prompts you to select from the locations assigned to the 
physical branch in which the terminal is located. Once a printer location is 
selected, you can also change it. 

Sales Sources The sales sources from which this user can enter orders. 

7. Assign the branches and territories for which the user is authorized to enter transactions. 

8. Assign order entry views and templates to the user. 

9. Assign authorization keys to the user. 

10. Use the Maintenance menu items to enter additional user data, as needed. 

To... Select this menu option... 
define authorized territories Maintenance > Territories 

Displays the Authorized Territories window. 

assign gross profit control parameters Maintenance > Gross Profit Control 
Displays the GP% Control Parameters window. 

create authorization passwords Maintenance > Authorization Passwords 
Displays the Authorization Passwords window. 

define user defaults for Solar Eclipse Maintenance > Solar Eclipse Options 
Displays the Solar Eclipse User Maintenance window. 

 

Note: The Password menu item is not active when creating a user record. 

11. Use the Additional menu items to enter additional user data, as needed. 

To... Select this menu option... 
assign time clock options Additional > Time Clock 

Displays the Time Clock Options window. 

set user job queue and tracker defaults Additional > Job Queue 
Displays the User Job Queue/Tracker Settings window. 

enter user scheduler parameters Additional > Scheduler 
Displays the Scheduler Parameters window. 

enter additional user data Additional > Miscellaneous Data 
Displays the Additional User Data  window. 
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To... Select this menu option... 
assign languages Additional > Language 

Displays the User Language window. 

define Palm and imaging user parameters Additional > Palm and Imaging Options 
Displays the User Palm Maintenance window. 

12. Save and exit the User Maintenance window. 

13. Continue with the next task. 

Setting a User's Password Parameters 
After creating a user record, the system prompts you to set the password parameters for the user. 

To set a user's password parameters: 

1. When you exit the User Maintenance window after creating a new user record, the system 
displays the Password Maintenance window. 

2. Complete the following fields to define the password requirements for this user. If you leave a 
field blank, that parameter has no restrictions.  

Password Parameter Description 
Minimum Password Length Minimum number of character for a password.  

Minimum Number of New 
Characters 

Minimum number of new characters you must include in a 
password. New characters are letters or symbols not appearing in the 
previous password.  

Minimum Number of 
Numeric Characters 

Minimum number of numbers that you must include in the 
password. This prevents the user from creating passwords solely 
using words. 

Minimum of Alphabetical 
Characters 

Minimum number of letters or symbols that you must include in the 
password. This prevents the user from entering passwords consisting 
solely of number sequences. 

3. Complete the following fields to define the password change parameters for this user: 

Password Parameter Description 
Suggest Change Every (days) Number of days the system recognizes the password before it 

displays a message suggesting that the password is changed. The 
user can still log onto the system without changing the password. 

Require Change Every (days) Number of days the system recognizes the password before it 
requires that the password is changed. The user can no longer log 
onto the system without changing the password. 

4. In the Enter New Password field, enter a password in lower case.  

Note: Do not use upper case characters for passwords. 

5. In the Verify Password field, enter the password again. 

The system saves the user record and returns you to a blank User Maintenance window.  
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Using Prototyping to Create User Records 
If you create a new user record right after having displayed or created another user record, the system 
prompts you to use the previous user's record as a prototype for the new one you are creating.  

If you use the prototype record, the system populates the fields in the new user record with the 
information, authorizations, and assignments from the previous record. Edit these settings as needed. 

To use prototyping to create user records: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

Note: You must be assigned the USER.MAINT.ALLOWED authorization key to access 
this window. 

2. Display the user record to use as a prototype. 

3. From the File menu, select New to display the Enter New User ID prompt, then type the new 
user ID and click OK. 

The system displays the following prompt: Use [record ID] as a prototype? 

Note: The system also displays this prompt when you press Esc to exit the displayed 
record. 

4. At the prompt, enter Yes. 

The system copies the authorization, account, and branch assignments from the previous user 
record. You can change these assignments, as needed.  

5. Change the information displayed in the remaining fields, as needed, for the new user.  

For example, enter the new user's name, address, and birth date.  

6. Save the user record. 

The system displays the Password Maintenance window. 

7. Create a password for this user. 
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Required User Record Information Overview 
When you set up a user record, some information is required. For each user record, you must make the 
following assignments before a user can begin to use the system: 

• Assign the branches and territories they can access to enter transactions and make inventory 
inquiries.  

• Assign the order entry views appropriate to their job functions. 

• Assign the authorization keys required for performing their job functions. 



Solar Eclipse Application Maintenance Rel. 8.7.4 

18 © 2012  Epicor Software Corporation. All rights reserved. 

Assigning Branches to Users 
Use the Accessible Branches Maintenance window to identify the branches and territories for which a 
user can enter transactions, such as sales orders or accounts payable. You can also designate the territory 
in which the user can make inventory inquiries. You can set up users to ship products out of a branch 
without giving them access to all information in that branch. 

A user's authorization at a branch is governed by whether that branch is included in an assigned inventory 
inquiry territory, home territory, or is the user's home branch and by the user's authorization key 
assignments. 

• If you assign a home branch, the user has full access to all functions at the branch, based on the 
user's authorization key assignments. 

To limit a user's authorization to ship material or place orders in that branch, set a flag in the 
Authorization column for that branch in the lower portion of the window. 

• If you assign a home territory, the user has full access to all functions at all the branches in the 
territory. 

Note: You cannot limit a user's authorizations to the branches in a home territory. 

• If you assign an inventory inquiry territory, the system displays data for the branches in that 
territory when the user makes inventory inquiries. 

To assign branches to a user: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User field, enter a user's ID to display the corresponding record. 

3. From the Maintenance menu, select Branch to display the User Accessible Branches 
Maintenance window. 

Note: You must be assigned the USER.BRANCH.MAINT authorization key to access 
and edit this window. 

4. In the Home Branch field, enter the branch where this user works. 

The system lists the home branch in the Branches column. By default, the Authorization column 
is blank, which gives the user full access to this branch. You can edit this field, as described in 
Step 8. 

5. To assign a home territory to the user, select the territory in the Home Territory field. 

Note: If you need to limit a user's authorizations for one or more branches in a territory, 
do not assign a home territory. To grant full or limited authorizations to 
designated branches, list the branches in the lower section of the screen, as 
described in Steps 7 and 8. 

6. To assign an inventory inquiry territory, enter the territory in the Inventory Inquiry Terr field. 

If you... Then, when this user does an inventory inquiry... 
enter a territory information for all the branches in that territory displays. 
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If you... Then, when this user does an inventory inquiry... 
leave the field 
blank 

the system determines what to display in the follow sequence: 
• If a home territory is assigned, information for the branches in that territory 

displays. 
• If a home branch is assigned, information for that branch displays. 
• If a home branch is not assigned, the user cannot do an inventory inquiry in 

any branch. 

7. In the Branches column, enter any branches to which you want to grant full or limited access.  

The system populates this column with the user's home branch. Enter additional branches, as 
needed. 

8. In the Authorized column for each branch listed in the Branches column, do one of the 
following: 

• Leave the field blank to grant access based on the user's authorization key assignments. 

• Select one of the following options to limit the user's access to the branch: 

• I-Only Inventory Inq - The branch is accessible to this user only for inventory inquiry. 

• S-Sales Orders/Inv Inq - The user can ship material out of this branch through sales order 
entry, but cannot enter orders at this branch. The branch is accessible to this user for 
inventory inquiry. 

9. Click OK to save this information and return to the User Maintenance window. 
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Authorization Key Assignment Overview 
Authorization keys define users' permissions to access functions in the system. Some keys have multiple 
levels of authority associated with them. For example, you can assign the AP.ALLOWED authorization 
key to give a user access to A/P Entry, in view-only mode for Level 1 or edit mode for Level 2.  

The SUPERUSER authorization key, located at the bottom of the list of Available Keys, assigns the 
highest level of all authorizations to a user. Assign this authorization key to the system administrator 
only. 

To grant permissions, the system administrator assigns authorization keys to user records. Use the 
Authorization Key/Template Maintenance window to assign and remove authorization keys. This 
window, which lists all the keys, is divided into two areas: 

• Available Keys – Lists the keys not assigned to the user. 

• Assigned Keys – Lists the keys assigned to the user. You also need to assign authorization levels to 
some of the keys. 

Each authorization key is either available or assigned. You can move keys from one area to the other. 

The system provides two shortcuts for assigning authorizations to users in your company who perform the 
same tasks: 

• Use the prototyping function in User Maintenance, where you create a new user by copying the 
record and authorizations of another user. 

• Create authorization key templates that represent groups of users. First assign authorization keys to 
templates, and then assign the appropriate templates to user IDs.  

Templates display along with the authorization keys on the Authorization Key/Template Maintenance 
window. You can assign multiple authorization keys and templates to a user ID. 

Changes to authorization keys are not effective until the user affected by the changes re-logs into the 
system. 
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Assigning Authorization Keys to Users 
Assign authorization keys to users to give them permission to access functions in the system. 

When you assign users authorization keys, you can assign them individual keys or authorization 
templates, such as *TP: insidesales for all inside salespersons. You can also assign a level of 
authorization for keys that have more than one level. For example, use the AP.ALLOWED authorization 
key to allow access to A/P Entry, in view-only mode for Level 1 or edit mode for Level 2.  

For some authorization keys, you must enter additional detail information. For example, for the 
MESSAGE.GROUP.TYPES authorization key, you need to select if they are Personal, Group, or 
Global. 

To assign authorization keys to a user: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Maintenance menu, select Authorization Keys to display the Authorization 
Key/Template Maintenance window. 

The Available Keys area lists defined templates and authorization keys. Templates have a prefix 
of *TP: and are listed first. 

Note: You must be assigned the USER.KEY.MAINT authorization key to access this 
screen. 

4. To assign a key or template, select the item in the Available Keys area and click the Assign >> 
button.  

The key or template name moves from the Available Keys area to the Key column of the 
Assigned Keys area. 

Note: To move the cursor to a designated key, enter all or part of the key name in the 
Find field.  

5. In the Auth Level field, change the assigned authorization level, as needed. The system assigns 
the lowest level to the user.  

Note: If you assign multiple templates to a user, make sure the authorizations in one 
template do not conflict with those in the other templates. 

6. When you assign any of the following authorization keys, you must enter additional detail 
information:  

With the assigned key selected, from the Edit menu, select Detail to display the Detail selection 
window. To add items to this window, position the cursor on a blank line and select from the list. 
Click OK to save the information and return to the Authorization Key/Template Maintenance 
window. 

Authorization Key Use to permit access to... 
GL.ACCOUNTS view and edit designated G/L accounts. 
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Authorization Key Use to permit access to... 
INVALID.PRODUCT.LINES sell all but a few product price lines. 

INVALID.VEN.TYPES all but a few designated types of vendor records. 

MESSAGE.GROUP.TYPES view and edit designated Message Groups. 

POE.SCHEDULE set the Line Item > Auto Scheduling option on the POE Body tab to 
a default value. 

SOE.CREDIT.REL.RANK release orders for customers.  

SOE.SCHEDULE set the Line Item > Auto Scheduling option on the SOE Body tab to 
a default value. 

TOE.SCHEDULE set the Line Item > Auto Scheduling option on the TOE Body tab to 
a default value. 

VALID.BLINES edit product records in designated buy lines. 

VALID.PLINES edit product records in designated price lines. 

VALID.PRODUCT.LINES sell only a few product price lines. 

VALID.VEN.TYPES designated types of vendor records.  

WIN.DIRECT.CREATE.DIR export a report from the system using the Windows Direct Options 
program. 

7. To remove a key or template, select the item in the Assigned Keys area and click the << Remove 
button.  

The key or template name moves from the Assigned Keys area to the Available Keys area. 

8. Click OK to return to the User Maintenance window. 
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Assigning Superuser Authorization 
The SUPERUSER authorization key, located at the bottom of the list of Available Keys, assigns the 
highest level of all authorization keys to a user. If the SUPERUSER authorization key is assigned, almost 
no other keys need to be assigned. This authorization key is intended for use by users who require access 
to every function with maximum privilege and is reserved for system administrators, their superiors, 
company owners, and Eclipse personnel. 

Because this authorization key gives unlimited capability within the system, assign it sparingly. We 
recommend that the system administrator set up one user ID with limited authorizations to use for 
everyday work and another ID, with superuser authorization, to use only when needed. The assigned 
superuser should change the password frequently. 

To test a system function with a lower level of authorization, a superuser can override the default level of 
authorization for a designated key. To do this, assign the designated authorization key, in addition to the 
SUPERUSER authorization key, with the override level or the related detail information that restricts the 
user's actions. Any authorization key assigned in addition to the SUPERUSER authorization key 
overrides the superuser level of authorization for that key. 

To assign superuser authorization: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display their record. 

3. From the Maintenance menu, select Authorization Keys to display the Authorization 
Key/Template Maintenance window. 

4. In the Available Keys area, position the cursor on the SUPERUSER authorization key and click 
the Assign >> button.  

The key moves from the Available Keys area to the Assigned Keys area. The system assigns the 
highest level of authorization for almost all authorization keys. 

5. The following authorization keys limit a user's access and require that you specify additional 
information when you assign them, using the Detail option on the Maintenance menu.  

When you assign the SUPERUSER authorization key, the following authorization keys are not 
included in the superuser's authorization: 

Authorization Key When this key is not assigned... 
AP.SIGNATURE.PRINT the user cannot print an imaged signature on checks. 

GL.ACCOUNTS the user can access all G/L accounts. 

INVALID.PRODUCT.LINES no product lines are invalid. 

INVALID.VEN.TYPES no vendor types are invalid. 

MESSAGE.GROUP.TYPES the user can access all message group types. 

POE.SCHEDULE the system does not set the Line Item > Auto Scheduling option on 
the POE Body tab to a default value. 

SOE.CREDIT.REL.RANK the user can release orders for any customer, based on the user's level 
assignment in the SOE.CREDIT.RELEASE authorization key.  
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Authorization Key When this key is not assigned... 
SOE.SCHEDULE the system does not set the Line Item > Auto Scheduling option on 

the SOE Body tab to a default value. 

TOE.SCHEDULE the system does not set the Line Item > Auto Scheduling option on 
the TOE Body tab to a default value. 

VALID.BLINES all buy lines are valid. 

VALID.PLINES all price lines are valid. 

VALID.PRODUCT.LINES all product lines are valid. 

VALID.VEN.TYPES all vendor types are valid. 

WIN.DIRECT.CREATE.DIR the user cannot export a report from the system using the Windows 
Direct Options program. 

6. Click OK to return to the User Maintenance window. 

Note: Changes to authorization keys are not effective until the user affected by the 
changes logs off and then logs back on. 
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Creating Authorization Key Templates 
An authorization key template is a group of user authorization keys that specifies the permissions required 
for a designated job function. When multiple users perform the same tasks in your company, create a 
template for that job function and then assign the template to each user. For example, you can create and 
assign one authorization key template for counter salespeople and another template for accounts payable 
personnel. 

To create an authorization key template: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. Use the Auth Keys hot key to display the Authorization Key/Template Maintenance window. 

The Available Keys area lists defined templates and authorization keys. Templates are at the top 
of the list and have a prefix of *TP. 

4. Move the cursor to a line that does not begin with an asterisk (*) and use the Template option to 
display the Authorization Key/Template Maintenance window. 

5. In the Template field, type the word new and press Enter, and then enter the new template ID to 
display the list of available authorization keys. 

You can assign authorization keys to the template now or you can create the template without 
assigning keys to it. To assign keys to it later, skip to step 8. 

6. To assign an authorization key to the template, select it in the Available Keys area and click the 
Assign >> button. 

The key name moves from the Available Keys area to the Assigned Keys area. If authorization 
levels are associated with the key, the system assigns the lowest level to the user, but you can 
change it. 

7. To remove an authorization key, select it in the Assigned Keys area and click the Remove >> 
button. 

The key name moves from the Assigned Keys area to the Available Keys area. 

8. Press Esc to save the template and return to the Authorization Key/Template Maintenance 
window for the User ID. 

The system prefixes the new template ID with *TP: and displays with the other template IDs at 
the top of the Available Keys area. 
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Copying Authorization Key Templates 
An alternative way to create authorization key templates is to copy and then edit existing templates. For 
example, you can copy an authorization key template for accounts payable personnel and then edit the 
new template with additional authorizations for accounts payable supervisors. 

To copy an authorization key template: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. Select the Maintenance > Authorization Keys option to display the Authorization 
Key/Template Maintenance window. 

The Available Keys area lists defined templates and authorization keys. Templates are at the top 
of the list and have a prefix of *TP. 

4. Position the cursor on the template to copy and use the Edit > Copy menu option. 

Note: You can also display the selected template and then use the Edit > Copy menu 
option.   

5. At the Enter new template ID prompt, enter a new name for the copied template. 

The system prefixes the new template ID with *TP: and displays it with the other template IDs at 
the top of the Available Keys area. 

6. Select the new template name and use the Edit > Template menu option to display the template 
in the Authorization Key/Template Maintenance window. Authorization keys assigned to the 
template display in the Assigned Keys area. 

7. Edit the template as follows: 

• To assign an authorization key to the template, select it in the Available Keys area and click 
the Assign >> button. 

The key name moves from the Available Keys area to the Assigned Keys area. If 
authorization levels are associated with the key, the system assigns the lowest level to the user, 
but you can change it, if needed. 

• To remove an authorization key, select it in the Assigned Keys area and click the Remove >> 
button.  

The key name moves from the Assigned Keys area to the Available Keys area. 

8. Save the template and return to the Authorization Key/Template Maintenance window for the 
user ID. 
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Editing Authorization Key Templates 
The Eclipse system ships with pre-defined templates that contain authorization keys associated with 
common job types.  

The following authorization key templates might be available: 

Template Is designed for... 
*TP:AR/AP accounts receivable and accounts payable personnel. 

*TP: MGR managers. 

*TP:SALES inside and outside salespeople. 

 You can modify these templates and create others as needed. The system prefaces templates with *TP: 
and all templates display at the beginning of the Available Keys list on the Authorization Key/Template 
Maintenance screen.  

To edit authorization key templates: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. Select the Maintenance > Authorization Keys option to display the Authorization 
Key/Template Maintenance window. 

The Available Keys area lists defined templates and authorization keys. Templates are at the top 
of the list and have a prefix of *TP. 

4. Position the cursor on the template to edit and use the Edit > Template option to display the 
Authorization Key/Template Maintenance window. Authorization keys assigned to the template 
display in the Assigned Keys area. 

5. To assign an authorization key to the template, select it in the Available Keys area and click the 
Assign button. 

The key name moves from the Available Keys area to the Assigned Keys area. If authorization 
levels are associated with the key, the system assigns the lowest level to the user, but you can 
change it, if needed. 

6. To remove an authorization key, select it in the Assigned Keys area and click the Remove 
button.  

The key name moves from the Assigned Keys area to the Available Keys area. 

7. Save the template and return to the Authorization Key/Template Maintenance window for the 
user ID. 
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Deleting Authorization Key Templates 
If you do not need an authorization key template, you can delete it. If you delete a template that is 
assigned to a user, that user will lose the authorization keys contained in that template. 

To delete an authorization key template: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. Select the Maintenance > Authorization Keys option to display the Authorization 
Key/Template Maintenance window. 

The Available Keys area lists defined templates and authorization keys. Templates are at the top 
of the list and have a prefix of *TP. 

4. Position the cursor on the template to delete and use the Edit > Template option to display the 
Authorization Key/Template Maintenance window. Authorization keys assigned to the template 
display in the Assigned Keys area. 

5. Select the File > Delete option. The system prompts you to confirm the deletion. 

The Authorization Key/Template Maintenance window for the user ID displays and the deleted 
template no longer displays in the Available Keys area. 
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Additional User Record Information Overview 
Once you have defined the general user defaults on the User Maintenance window, use the window's 
menu options to define defaults for special functions. 

For example: You may need to assign GP% control parameters to users in sales, to limit the amount by 
which they can override sales prices. You may also want to assign authorization passwords to the 
managers in sales so that they can make pricing adjustments.  

If your company uses any of the following companion products, you need to set user defaults: 

• Document Imaging - Assign a default document imaging profiles to users.  

• Outbound E-mail - Set up default information to populate the Send E-mail screen whenever users 
send e-mail messages from the system. 

• RF Warehouse Management - Define users' pick groups. 

• Eclipse Information System (EIS) - Define the business areas for which users can generate 
graphs. 

• Time Clock - Set user options, such as whether the system should clock users out after a certain 
time of day. 

For customer, vendors, or contacts for whom you have defined user records, you need to link these user 
records with the correct customer, vendor, or contact record. Set additional user defaults for the message 
system, printers, territory assignments, job queues, and scheduler. In addition, you can set user defaults 
for users who access Solar Eclipse to perform their job functions. 
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Assigning Gross Profit Percent Control Parameters to Users 
Use the gross profit percent (GP%)  control parameters to limit the amount by which a user can override 
sales prices. The user must be authorized to edit prices and costs on sales orders. You can define a 
minimum gross profit percentage and a maximum discount from the standard price allowed for stock and 
direct items. If the user makes a change that exceeds the limit, a warning message displays. 

Note: The Base Minimum GP% Price Check Off COMM-COST control maintenance 
record determines whether you base the minimum GP% price check off COMM-
COST or  COGS cost. 

Minimum Gross Profit Percentage 
The system uses the minimum gross profit percentage to prevent users from selling products for less than 
a designated minimum.  

You can assign a minimum required GP% at the following levels: 

• Order 

• Product 

• Price Line 

• User 

When the user makes a change that affects the GP% for an item in sales order entry, the system looks for 
a specified minimum, in the sequence listed above. The system stops checking once it finds one setting 
for minimum GP%, and does not check subsequent settings. If the new GP% falls below the first detected 
minimum, the system displays a warning that identifies the parameter (product, price line, user) affected 
by the change and what the minimum GP% for that level is. To override the warning, the user must be 
assigned the SOE.MIN.GP authorization key. 

Maximum Discount from Standard Price 
The system uses the maximum discount from standard price to prevent users from discounting the price of 
a product more than a designated maximum. 

When the user makes a price change that affects the discount from the standard price for an item in sales 
order entry, the system compares the new discount to the maximum specified in this field. If the new 
discount is greater than the maximum, the system displays a warning that the new sales price exceeds the 
maximum percentage the user is allowed to discount from the standard sales price. To override the 
warning, the user must be assigned the SOE.MIN.GP authorization key. 

To assign GP% control parameters to users: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Maintenance menu, select Gross Profit Control to display the GP% Control 
Parameters window. 

4. For stock and direct items, in the Minimum GP % Required field, enter the minimum gross 
profit percentage that this user can specify on an order.  
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5. For stock and direct items, in the Maximum Discount from Standard Price field, enter the 
maximum percentage discount on the standard price that this user can specify on an order. 

6. Click OK to save this information and return to the User Maintenance window. 

7. Save the user record. 
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Assigning Languages to Users 
Use the User Language window to designate the languages in which this user can work.  

The user's default language is the first language in the list. If left blank, the default language is English.     

To assign languages to a user: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Language to display the User Language window. 

4. Do the following, as needed: 

• To add a language, position the cursor on a blank line and select a language. 

• To delete a language, position the cursor on the language and press Alt-Delete. 

5. Click OK to save this information and return to the User Maintenance window. 

6. Save the updated user record. 
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Assigning Maintenance Users to User IDs 
When you have a user ID that represents a group, you need to designate other users to monitor the user 
job queue for this ID and respond to the trackers in the queue. For example, you might have a user ID 
called INFOREQ, to whom people in your company can submit trackers requesting information.  

Use the Maintenance User Selection screen to identify the additional users authorized to maintain a user 
record that represents a group, and respond to and close trackers that require final action by this user ID. 

To assign maintenance users to a user ID: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Job Queue to display the User Job Queue/Tracker Settings 
window. 

4. Select the Limit Access to Maintenance Users option to allow only the maintenance users 
defined for this ID to perform the following tasks:  

• Add or delete this ID from the forwarding list. 

• View the User Job Queue for this user ID. 

• Change the followup status on that queue. 

5. From the Edit menu, select Job Queue Maintenance Users to display the Maintenance User 
Selection window. 

6. For each maintenance user, do the following: 

• In the User Name column, enter the maintenance user's ID. 

• In the Append Name column, select how the system describes the appends the maintenance 
user makes to trackers in the job queue. 

• Group ID - Displays the group user ID. 

• User ID - Displays the maintenance user ID. This is the default. 

• Group & User ID - Displays the group user ID followed by the maintenance user ID in 
parentheses. 

7. Save the information and exit the window. 

8. Continue exiting windows until you have saved the updated user record. 
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Creating Authorization Passwords for Users 
Managers can create one-time or multiple-use authorization passwords to enable other users to complete 
authorization-protected tasks on an as-needed basis. This allows for greater security and auditing 
capability since managers no longer have to share their personal passwords. It also increases productivity 
since a manager no longer needs to be at a workstation to authorize specific tasks. 

For example, only authorized users can approve pricing adjustments that exceed defined limits. Typically 
these users are in management positions. When a non-authorized user enters a pricing adjustment in order 
entry that exceeds the designated limits, the system displays the following prompt: Enter Authorized 
Password.  

Two ways to respond to this prompt are:  

• Authorized users can enter their Eclipse password at the prompt. For example, an authorized 
manager walks over to the order taker's terminal and enters the manager's Eclipse password. 

• Authorized users can create authorization passwords, which they can tell another user to enter on 
their behalf. The user requesting the override enters the authorization password at the prompt. This 
eliminates the need for a manager to walk over to the other user's terminal to respond to the 
prompt. 

To create authorization passwords, managers must be assigned the AUTH.PWD.MAINT authorization 
key. They can create one-time or multiple-use passwords, depending on the level assigned to the key. 

Every time a user enters an authorization password at the Enter Authorized Password prompt, the 
system sends a message to the user who created the password. The message describes the password, who 
used it, and the reason for using it.  

• If the message is for a one-time password, it also indicates that the password is now expired.  

• When the system determines that a multiple-use password has expired, it sends a message to the 
user who created it. 

To create authorization passwords for users: 

1. Do one of the following to display the Authorization Passwords window: 

• From the System > System Files > User Control menu, select Authorization Password 
Maintenance. 

• From the User Maintenance window, select Maintenance > Authorization Passwords. 

2. In the Login Password field, enter the user's system password to access the password definition 
area of the window. 

3. In the Password field, enter a password. The system populates the remaining columns as follows: 

If your authorization 
level is... 

Then the password is set for... 

0 one-time use. You cannot change this setting. The system deletes the 
password from the list after the first use.  
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If your authorization 
level is... 

Then the password is set for... 

1-998 multiple use for the number of days equal to the level number. If you 
change the date, it cannot be later than the system-generated date or 
earlier than the current date. The system deletes the password from the list 
following the expiration date. 

999 multiple use with no expiration date. The password is available for use 
until you remove it from the list. 

4. To allow the password to be used just once, select the One Time option. 

5. To allow the password to be used multiple times for a limited period, enter an expiration date in 
the Expire Date field.  

Note: This field does not apply if the password is set up for one-time use. 

6. Repeat steps 3 through 5 to set up additional authorization passwords. 

7. Click OK to save this information and return to the User Maintenance window. 

8. Save the updated user record. 
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Defining Authorized Territories for Users 
Territories are groups of branches defined in Territory Maintenance. Companies generally use territories 
for inquiry and reporting purposes. Users can have different levels of access to territories. You can 
authorize some users to use territories only for reporting purposes and others to view and edit the 
branches assigned to the territories. 

The system utility called Rebuild Authorized Territory Lists generates default lists of authorized 
territories for users, based on the users' assigned branches and the parameters used to define the 
territories. Each user has three types of authorized territories: reporting, viewable, and editable. You can 
assign each territory to multiple authorized territory types.  

Use the Authorized Territories window to view users' default territory lists and to override the defaults, if 
necessary. 

To define authorized territories for users: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Maintenance menu, select Territories to display the Authorized Territories window. 

Note: You must be assigned the USER.TERR.MAINT authorization key to access this 
window. 

4. At the top of the window, select a territory type to determine a user's authorization: 

• Reporting - Territories for which the user can run reports. The default list of reporting 
territories displayed for a user includes every territory in which the user has an accessible 
branch. Any territory can be included in the reporting list. When running a report for a 
territory, only information for branches to which the user has access within the territory is 
included in the report. 

We recommend that you do not change the default list of reporting territories. Let the 
Rebuild Authorized Territory Lists utility maintain this list. 

• Viewable - Territories whose data the user can see in view-only mode. The default list of 
viewable territories displayed for a user includes every territory in which the user has an 
assigned branch. A territory must have an entity priority or product priority defined on the 
Territory Maintenance window to be included in the viewable list. 

• Editable - Territories whose data the user can edit. The default list of editable territories 
displayed for a user includes only those territories in which every branch is assigned to the 
user. A territory assigned to the editable list overrides a user's accessible branches. Even if the 
user does not have access to all branches in the listed territory, the user can change the settings 
for the territory. A territory must have an entity priority or product priority defined for it on the 
Territory Maintenance screen to be included in the editable list. 

The system displays the territories included in the selected type. 

Note: The following steps apply to the type you selected in this step. You can work with 
only one territory type at a time. 
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5. To prevent the system from updating the list of territories defined for the selected territory type 
when the Rebuild Authorized Territory Lists utility runs, select the Override Automatic Build 
option. 

6. To authorize the user for all territories for the selected territory type, select the Authorized for 
All Territories option. 

For the Viewable territory type: 

• Selecting this option authorizes the user to view all territory information on any window. 

• Not selecting this option prevents the user from viewing any territory information on any 
window. This also removes all territories from the user's list. 

For the Editable territory type: 

• Selecting this option authorizes the user to edit all territory information on any window. 

• Not selecting this option prevents the user from editing any territory information on any 
window. This also removes all territories from the user's list. 

7. Repeat steps 4 through 6 for each territory type. 

8. Click OK to save this information and return to the User Maintenance window. 

9. Save the user record. 
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Defining Palm and Imaging User Parameters 
Use the User Palm Maintenance window to define the following: 

• Parameters for downloading price line and buy line information to user Palm devices. 

The system filters the buy lines and price lines users can download to their Palm devices for 
placing orders using Pocket OE. The Valid Palm Buy Line Product Download and Valid Palm 
Price Line Product Download control maintenance records define system-level defaults. You 
can override the system-level defaults by defining user-specific product download parameters. 

The system only downloads products assigned to the buy lines and price lines defined for a user. 
If no price or buy lines are defined at the user level, the system downloads products assigned to 
the buy lines and price lines defined in the control maintenance records. 

• Default document imaging profiles for users. 

If your company uses the Eclipse Document Imaging companion product, you can assign default 
document imaging profiles to users for attaching documents to records in the system. Document 
profiles define storage paths and how the system indexes the images using that profile. 

To define Palm user parameters: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Palm and Imaging Options to display the User Palm 
Maintenance window. 

4. In the Product Price Lines to Download field, select the price lines this user can download to 
their Palm device.  

5. In the Product Buy Lines to Download field, select the buy lines this user can download to their 
Palm device. 

6. In the Product Availability Branch field, select the branches or territory for which to download 
product availability for this user.  

When the user syncs their Palm device, the product availability downloaded to the reorder pad is 
a cumulative tally of the product’s availability for each branch entered in this field. If you leave 
this field blank, the system downloads availability for the user’s home branch. Wireless Pocket 
Order Entry attempts to download availability for the pricing branch entered in the Real Time 
Preferences screen. If the Pricing branch is blank, the wireless palm functionality downloads 
availability for the user’s home branch. 

When the user requests a wireless price update, the palm device displays the availability at each 
branch and a total cumulative tally.  

7. Click OK to save this information and return to the User Maintenance window. 

8. Save the user record. 

To define imaging parameters for a user: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 
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2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Palm and Imaging Options to display the User Palm 
Maintenance window. 

4. In the Default Imaging profile field, enter the default document imaging profile for this user. 

5. Click OK to save this information and return to the User Maintenance window. 

6. Save the user record. 
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Defining User Defaults for Solar Eclipse 
If your company uses the Solar Eclipse graphical user interface, access the Solar Eclipse User 
Maintenance window to define additional defaults for the user. For example, Solar Eclipse can play 
different tunes that identify the types of messages you receive. 

Each user is allowed one Solar Eclipse license per machine up until you reach your license count. 

To define user defaults for Solar Eclipse: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Maintenance menu, select Solar Eclipse Options to display the Solar Eclipse User 
Maintenance window. 

4. In the Solar Main Menu field, select the default main menu to display for this user. If you leave 
this field blank, the system displays the user's root menu defined for the character-based system. 

5. In the Custom Toolbar Template field, select the user's default template for the user-defined 
toolbar. 

6. In the Messages field, select the tune to play in Solar Eclipse when the user receives a message. 

7. In the Job Queues field, select the tune to play in Solar Eclipse when the user receives a tracker 
in their job queue. 

8. In the Reports field, select the tune to play in Solar Eclipse when the user receives a report that 
the Hold file forwarded. 

9. Click OK to save this information and return to the User Maintenance window.  

10. Save the user record. 
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Entering Additional User Data 
Use the Additional User Data window to add any of the following miscellaneous information to a user 
record: 

• EIS Groups 

• User Expense Parameters 

• Outgoing E-mail Parameters 

• User Entity Data 

• Messaging Options 

• User Warehouse Options 

• Default Message for Faxed Orders 

Assigning EIS Groups to Users 
The Eclipse Information System (EIS) is a companion product that management can use to display 
selected business data in graphical format. EIS groups, such as Sales and Purchases, define the business 
areas for which a user can generate graphs. 

If your company uses the Eclipse Information System, you need to assign EIS groups to users. Users can 
only generate graphical information for the groups assigned to their ID. Users with no groups assigned 
cannot access the EIS application. 

To assign EIS groups to users: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Additional User Data to display the Additional User Data 
window. 

4. In the EIS Groups area of the screen, in the EIS Groups field, select the groups to assign to this 
user. 

5. Click OK to save this information and return to the User Maintenance window. 

6. Save the user record. 

Entering User Expense Parameters 
If your company reimburses a user for expenses, designate the payee name for expense checks for this 
user and the IDs of users authorized to sign off on the expense. The payee must be set up as a vendor 
record. 

To enter user expense parameters: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 
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3. From the Additional menu, select Additional User Data to display the Additional User Data 
window. 

4. Complete the following fields in the User Expense Parameters area of the screen: 

• In the Pay To field, enter the name of the vendor to display on expense checks for this user. 

• In the Signoff fields, enter up to four IDs of users who must authorize this user's expenses 
before the system can create an expense check for the user. 

5. Click OK to save this information and return to the User Maintenance window. 

6. Save the user record. 

Setting User Outgoing E-mail Parameters 
Use the Outgoing E-mail Parameters area of the Additional User Data window to set up default 
information with which to populate the Send E-mail window whenever a user sends an e-mail message 
from the system. These defaults identify the e-mail address of the person sending the message and, if 
needed, the e-mail address that receives a blind carbon copy of the message sent.  

This feature is available only if you use the Outbound E-mail companion product. 

To set user outgoing e-mail parameters: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Additional User Data to display the Additional User Data 
window. 

4. Complete the following fields in the Outgoing E-mail Parameters area of the screen: 

• In the E-mail field, do one of the following: 

• To have the system populate the From field on the Send E-mail window with the user's ID 
and company domain name, leave the field blank. For example, the system populates the 
field with userID@eclispedistributor.com. 

• If it is different from the default generated by the system, enter the user's e-mail address in 
this field. 

• If the user wants to receive a blind carbon copy of each e-mail the user sends, enter the user's e-
mail address in the Sender BCC field. 

• To append an identifying prefix to the Subject line of the blind carbon copy e-mail, enter the 
prefix in the Sender BCC Subject Prefix field. 

• Select the Forward Messages to E-mail check box if you are running the Eclipse Integration 
with Microsoft Outlook companion product and you want this user to receive system messages 
and tracker appends in their e-mail inbox.  

Use this feature if this user is frequently logged out of Eclipse but still needs to receive 
information for the trackers for which they are on the forward list, as well as system message 
communications. 

5. Click OK to save this information and return to the User Maintenance window. 
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6. Save the user record. 

Entering User Entity Data  
Users are the people who use the Eclipse system. The system stores a record for each user in User 
Maintenance. In some cases, users may also be customers, contacts, and vendors. When this occurs, you 
must first create a record in the system for the entity and then attach the name on that record to the user's 
maintenance record. For example: 

• For a user to purchase items from your company, the user must have a record in Customer 
Maintenance.  

• For a user to submit bills or expense reports to your company, the user must have a record in 
Vendor Maintenance.  

• To store address, phone and fax number information for a user, the user must have a record in 
Contact Maintenance. 

From User Maintenance, you can then access the Additional User Data window to link a user to their 
corresponding customer, contact or vendor record.  

To enter user entity data: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Additional User Data to display the Additional User Data 
window. 

4. Complete the following fields in the User Entity Data area of the window as needed: 

• In the Customer field, enter the name of the customer with which this user is associated. 

• In the Vendor field, enter the name of the vendor with which this user is associated. 

• In the Contact field, enter the name of the contact with which this user is associated. 

5. Click OK to save this information and return to the User Maintenance window. 

6. Save the user record. 

Defining User Messaging Options 
Use the Messaging Options area of this window to specify user defaults related to the Message System. 
For example, you can specify the screen that displays when you press Ctrl-F8 and the maximum number 
of messages to store for the user. 

You can also assign users to and remove them from message groups.  

To define user messaging options: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 
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3. From the Additional menu, select Additional User Data to display the Additional User Data 
window. 

4. Complete the following fields in the Messaging Options area of the window, as needed: 

• In the Message Groups field, click the Multiple Item button to display the Message Groups 
window, which lists the message groups to which this user is assigned. Add and delete 
message groups, as needed, and then click OK to save this information and return to the 
Additional User Data window. 

Note: If the user is assigned the MESSAGE.GROUP.TYPES authorization key, the 
selection list contains only those groups for which the user is authorized. 

• In the Message Default field, select whether Ctrl-F8 displays the Received Messages screen 
or the Message Dialog screen. 

• R-Review - Displays the Received Messages screen. 

• D-Dialog - Displays the Message Dialog screen. This is the default value. 

• In the Maximum Number of Messages field, enter the maximum number of messages to keep 
in the message system for this user. When the number of messages reaches the maximum, the 
system deletes the oldest messages as new messages arrive. 

• In the New Message Notification field, select how the system notifies this user each time the 
user receives a new message: 

• Scrolling Notification - The newest received message scrolls across the bottom of the 
screen until the user accesses the Message System and views the received messages. This is 
the default method. 

• Single Notification - The following notification message displays at the bottom of the 
screen: x New Message Waiting, where x indicates the number of received messages the 
user has not yet viewed. This message displays until the user accesses the Message System 
and views the received messages.  

• No Notification - The system never displays any message notification at the bottom of the 
screen. 

5. Click OK to save this information and return to the User Maintenance window. 

6. Save the user record. 

Entering User Warehouse Options 
A large warehouse operation can be divided into zones. Pickers, who select items from the shelves to fill 
orders, can belong to pick groups associated with each zone. For example, you might have a pick group 
W for the warehouse and pick group Y for the yard. When the warehouse picker selects orders to pick, 
the system prompts for the pick group. If the picker enters W, only those picks from the W area display. 

If a user always picks in the same location, you can specify a default pick group for the user. This default 
displays on the picker's terminal without prompting the user. 

To enter user warehouse options: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 
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2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Additional User Data to display the Additional User Data 
window. 

4. Complete the following fields in the User Warehouse Options area of the window as needed: 

• In the Pick Group Default field, do one of the following: 

• Enter the default pick group to display for this user when the user logs into RF Picking.  

• Enter ALL to display all pick groups when the user logs into RF Picking. 

• In the Location Maint View field, select the user's default view for the Product Location 
Maintenance window. 

• In the Display Warning if Receiving in Incorrect Branch field, select whether the system 
displays a warning when a user displays a purchase order or stock receipt whose receiving 
branch does not match the branch from which the user is working.  

• Never - Does not display a warning. 

• Both - Displays a warning from purchase order entry and stock receipts. 

• POE - Displays a warning from purchase order entry. 

• Stock Receipts - Displays a warning from stock receipts. 

Note: The setting in this field does not restrict the user from editing or receiving the 
purchase order, regardless of what the receive branch of the purchase order may 
be. 

5. Click OK to save this information and return to the User Maintenance window. 

6. Save the user record. 

Defining a Default Message for Faxed Orders 
If defined, the system can display a user-specific message on the cover sheet when a user faxes an order. 

To define a default message for faxed orders: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Additional User Data to display the Additional User Data 
window. 

4. In the Fax Default Message for Order Entry field, enter the message that the system displays 
on the cover sheet of all faxed orders this user creates. 

5. Click OK to save this information and return to the User Maintenance window. 

6. Save the user record. 
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Entering User Scheduler Parameters 
The scheduler maintains calendars of scheduled events and tasks for users. Each use can use the scheduler 
to organize and track events. In addition, the user can use the scheduler to determine where other users are 
working and when they are available for meetings.  

Use the Scheduler Parameters screen to enter default scheduler information for users. For example, you 
can display users' standard office hours in their schedule and determine when the system should prompt 
them to enter a day's schedule. 

You can also use this screen to designate a user ID as a scheduling location, such as a conference room.  

To enter user scheduler parameters: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Scheduler to display the Scheduler Parameters window.  

4. If the user works the standard office hours set up for your company and a template user ID has 
been set up with those hours scheduled, enter the template ID to copy the schedule set up for that 
ID into this user's schedule in the User for Availability field. 

Note: The system copies all events with the Available and Busy statuses defined for the 
template user to this user's record. 

5. In the Prompt for Schedule on Login field, indicate whether to prompt this user to make an 
entry in the Daily Planner or their Daily Schedule when they log in. If you leave this field blank, 
the default is Empty.  

The option specified in the Check Scheduler On Login control maintenance record determines 
the type of prompt that displays. If the No Planner option is flagged on the User Maintenance 
screen, the system ignores the setting in this field. 

Select from the following choices: 

If this 
field is set 
to... 

And the Check 
Scheduler on Login 
control maintenance 
record is set to... 

Then the system... 

Empty No Check never prompts the user. 

Daily Planner 
 

prompts the user to enter the day's schedule if the Daily 
Planner for that day is empty. To exit the prompt, the user 
must enter a comment describing the day's schedule.  

Daily Scheduler 
 

displays the Daily Schedule window if no one has 
scheduled events for that day. To exit the window, the 
user must schedule at least one event. 

Always No Check never prompts the user. 

Daily Planner always prompts the user to enter the day's schedule. To 
exit the prompt, the user must enter a comment describing 
the day's schedule.  
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If this 
field is set 
to... 

And the Check 
Scheduler on Login 
control maintenance 
record is set to... 

Then the system... 

Daily Scheduler always displays the Daily Schedule window. To exit the 
window, the user must schedule at least one event. 

Never No Check never prompts the user. 

Daily Planner never prompts the user. 

Daily Scheduler never prompts the user. 

6. In the Prompt for Schedule on Logout field, select one of the following options to indicate 
whether the system should prompt this user to enter the day's schedule in the Daily Planner when 
they log out. 

• Empty - Prompts the user to enter the day's schedule if the Daily Planner for that day is empty. 

• Always - Always prompts the user to enter the day's schedule.  

• Never - Never prompts the user to create an entry in the Daily Planner. This is the default 
value. 

Note: The setting in this field applies only if the Check Scheduler On Login control 
maintenance record is set to Daily Planner. If the No Schedule Prompting option 
is flagged on the User Maintenance window, the system ignores the setting in this 
field. 

7. In the Default Schedule Alarm Time field, enter the default amount of time in minutes, hours, or 
days that the scheduler alerts the user before scheduled events. 

8. In the Prompt for Closing Notes field, indicate whether you want the system to display the 
Closing Notes prompt whenever this user marks an event as completed. 

Note: A value entered in this field overrides the setting in the Prompt For Scheduler 
Closing Notes control maintenance record. If you leave this field blank, the 
control record determines whether the closing notes screen displays. 

9. To treat this user as a scheduler location, such a conference room, select the Location User 
option. 

If you select this option, the system displays this user in the selection list for the Location field 
on the Schedule Detail Maintenance window. 

10. In the Allow Outlook to Control Schedule field, enter Yes if you are using Eclipse Outlook 
Integration and want your schedule in Eclipse to contain the appointments that are in your 
Microsoft Outlook calendar. 

11. Click OK to save this information and return to the User Maintenance window. 

12. Save the user record. 
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Setting User Job Queue and Tracker Defaults 
Use the User Job Queue/Tracker Settings screen to:  

• Designate default information for populating the Call Tracking System screen when the user 
creates a tracker.  

• Identify additional users authorized to maintain this user record and close trackers that require final 
action by this user ID. This is useful when the user is set up for a queue, such as REQUESTS, and 
is monitored by other authorized users. 

• Create a list of job queue statuses available for this user ID in addition to the User Job Queue 
Statuses defined in Control Maintenance. Users can use these personal lists to organize their job 
queues using their own statuses. 

To set user job queue and tracker defaults: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User field, enter a user's ID to display the corresponding record. 

3. From the Additional menu, select Job Queue to display the User Job Queue/Tracker Settings 
window. 

4. Complete the following fields to designate default values for the Call Tracking System window 
when this user creates a new tracker: 

Field Description 
Category  Select the default category to which trackers created by this user are assigned. The 

selected category determines the values available to the Work Area and Sub Area 
fields on the Call Tracking System window.  

Source  Select the default source that displays in the Source field. 

Priority  Select the default priority that displays in the Priority field 

External Status  Select the default external status that displays in the External Status field. The 
system default status is Newitem. 

Internal Status  Select the default internal status that displays in the Internal Status field. The 
system default status is Newitem. 

Internal Stage For internal Eclipse use only.   
Enter the default process flow stage the system uses when a supervisor assigns this 
user to a tracker.  

Initial Entry Select whether to position the cursor on a new tracker's Call Tracking Entry screen 
on the Category or Sub Area field.  

Note: If you specify a default value for the Category field, then position the cursor 
on the Sub Area field. 

5. In the Display Options field, select one of the following default views for this user's User Job 
Queue Viewing screen: 

• Original Comment 
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• Release Notes 

• Keywords 

• Problem Solution 

6. In the Append View Options field, select the type of appends this user can view. If you leave 
this field blank, the user can view all appends. 

7. In the Valid Sources field, enter a list of sources this user can enter in the Source field on the 
Call Tracking System screen, indicating where the tracker originated. 

8. To create a list of user-defined job queue statuses for this user ID, in the Valid Statuses field, 
click the Multiple Item button to display the User Job Queue Statuses window. Then enter the 
statuses. Do either of the following: 

• To add a status to the list, position the cursor on a blank line and type the status. 

• To remove a status from the list, position the cursor on the status to remove and press Alt-
Delete 

The user can use the statuses listed here in addition to the Valid User Job Queue Statuses defined 
in Control Maintenance. 

Note: The User Job Queue Viewing window sorts the trackers in your queue by status 
and displays them in the same order in which the statuses are entered on this 
screen. 

9. In the Send Tracker Message on Update/Addition by Owner field, select one of the following 
options to determine when the system sends a message to users on the forward list if the tracker 
owner updates the tracker: 

• Never - Never send a message. 

• New - Send a message only when the tracker owner appends a new comment. 

• All - Send a message whenever the tracker owner updates a previous comment or appends a 
new comment. 

10. If the displayed user is set up as a queue, select the Limit Access to Maintenance Users option 
to allow only the maintenance users defined for this ID to perform the following tasks:  

• Add or delete this ID from the forwarding list. 

• View the User Job Queue for this user ID. 

• Change the followup status on that queue. 

11. To assign maintenance users, from the Edit menu, select the Job Queue Maintenance Users 
option. 

12. Click OK to save this information and return to the User Maintenance window. 

13. Save the user record. 
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Custom Menus Overview 
The system ships with a standard menu structure called MAIN, which provides access to all system 
applications. To give a user access to all the system applications, assign MAIN as the user's root menu in 
User Maintenance. When the user logs in to Eclipse, the root menu displays across the top of the window 
and provides access to the application menus.  

Note: If an application, such as Customer Maintenance, requires authorization to access, 
and the user does not have the required authorization assigned in User 
Maintenance, the menus display without the application.  

From each application menu, users can access the functions and additional menu options associated with 
that application. For example, from the System menu users can select Message System to display the 
Message System program or System Files to display the System Files menu. 

You and your installer can create user-defined, custom menus to meet your company's needs. For 
example, if your company does not sell products that require material safety data sheets (MSDS), you can 
create a user-defined Files menu and remove the MSDS option. Then you can create a user-defined 
MAIN menu and replace the link to the standard Files menu with a link to your user-defined Files menu. 

Use this process to create variations of the MAIN menu for different user groups within your company. 
Then, in User Maintenance, assign each user the root menu that corresponds to the user's job function. 
Use custom menus to determine which programs users can access, simplify navigation for users, and 
create unique menus for users with special functions. You can also add custom menus for custom 
programming on your site, as well as report writer and G/L reports that you have defined for your 
business to a menu.  

Important: You cannot modify the standard menus shipped with the Eclipse system. Upgrades 
to future software releases override the standard menu set. You need to create 
copies of the standard menus to make changes to the contents of the menus. 
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Searching Source Menus 
As you are creating your custom menus, you can filter the available menus to select from in Menu 
Maintenance, as well as search by keyword to find the menu or window you want to add to your custom 
menu. 

To search for a source menu: 

1. From the System > System Files > User Control menu, select Menu Maintenance to display 
the Menu Maintenance window. 

2. In the Menu field on the right side of the window, select the menu ID you want to edit, or click 
New to create a new menu.  

3. On the left side of the window, select the Select from top-level menus only check box to search 
for only menus that call other menus.  

For example, the ORDERS menu calls the CONSIGNMENT menu and the INQUIRIES menu, 
along with many others. To filter using all menus, deselect this check box. 

4. In the Source Menu field, select the menu you want to display. To display the standard Eclipse 
main menu, select MAIN. 

The list also includes any custom menus you have created and saved.  

To search for a menu or item within a source menu: 

1. From the System > System Files > User Control menu, select Menu Maintenance to display 
the Menu Maintenance window. 

2. Search for a source menu as described above. 

3. In the Search field, type all or a portion of a word in the menu or the window you want to find. 

The system highlights the first occurrence of the keyword in the Main Menu list. Click the Next 
button to highlight the next occurrence of the word, and use the Previous button to search the list 
in ascending order. 



Solar Eclipse Application Maintenance Rel. 8.7.4 

52 © 2012  Epicor Software Corporation. All rights reserved. 

Creating Custom Menus Using Standard Eclipse Menus 
Custom menus are variations of standard menus that reflect the needs of your installation. Assign custom 
menus to users according to their job function. The menus determine which programs users can access. 

You can create custom menus by copying subsets of the standard menus that come with Eclipse, or you 
can modify an existing menu and build your menu from scratch. 

After you create a custom main menu, assign it in User Maintenance as the root menu for the appropriate 
users. If you create a custom submenu, assign it to a menu to which the users you created it for have 
access. 

Note: Any menu you create using Menu Maintenance is available in Eterm and Solar if 
the menu is setup to work in both interfaces. However, for a menu option to work 
in Eterm, it must have an Eterm program name, and for it to work in Solar, it must 
have a Java Program and Class.  

To create a custom menu with standard Eclipse Menus: 

1. From the System > System Files > User Control menu, select Menu Maintenance to display 
the Menu Maintenance window. 

2. On the right side of the window, click New to create a new menu, enter an ID for the menu at the 
prompt, and click OK.  

Name the menu so you can identify it later when assigning it to your users or adding it to other 
menus. For example, if you are creating a menu for your counter personnel, you might name the 
menu CTR.MAIN. 

To modify an existing custom menu, select the menu ID in the Menu field to display the details 
of the existing menu. 

3. In the Main Menus list, select the menu or window you want to add to your menu and either drag 
and drop it to the Menu Detail for your custom menu, or click Add.   

If you selected a menu, the entire contents of the menu is added to your custom menu. This 
includes all the submenus under a menu as well as the titles and shortcut keys for each menu 
option. To view the menu names as they display in the Eterm interface, select View > View 
Eterm Titles. 
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Important: You cannot modify a main menu or the windows available under a main menu, 
because you lose your changes each time your system is upgraded. For 
information about using a main menu as a starting point and then modifying its 
contents, see Editing Standard Menu Contents Within Custom Menus. 
 
You can rename individual window options if you added them separately and they 
are not a part of main menu. 

4. Continue adding menus or windows, and add additional menu options, as necessary, including 
Report Writer reports, mass loads, G/L reports, or custom programming. 

5. From the File menu, select Save to save your custom menu.  

The custom menu is now available for selection in the Main Menus list to search for only menus 
that call other menus. 
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Editing Standard Menu Contents Within Custom Menus 
As you are creating your custom menus, you might find that you want only a portion of a standard Eclipse 
menu, or that you want to rename a menu option or assign a different shortcut key.  To protect your 
custom menus, you cannot edit a standard menu, because you lose your changes the next time your 
software is upgraded. However, you can create a copy of a standard menu and modify it to meet your 
needs.  

As you work with your custom menus, you can identify which menus are standard and which menus are 
copies that you can modify by the icons that display next to each menu in the menu details. 

• - Indicates a standard Eclipse menu that you cannot change. 

• - Indicates a copy of a standard menu that you can add to or remove content from, rename, or 
change the shortcut keys.  

Any menu you create using Menu Maintenance is available in Eterm and in Solar. 

To edit a standard menu within a custom menu: 

1. From the System > System Files > User Control menu, select Menu Maintenance to display 
the Menu Maintenance window. 

2. On the right side of the window, select the menu ID you want to edit in the Menu field, or click 
New to create a new menu.  

3. Do any of the following to modify the contents of your custom menu. 

The title and shortcut keys that display in the Title and Shortcut Key fields display for either 
Eterm or Solar, depending on whether the View > View Eterm Titles menu option is selected. To 
see both Eterm and Solar's titles and shortcut keys for a selected menu, click the Advanced 
button. 

To... Do this... 
change the title or shortcut to a window 
that is not contained in a standard menu 

 

select the window in your custom menu details, and 
update the information in the Title or Shortcut Key 
fields.  

change the title or shortcut to a main menu 
in the main menu bar 

 

select the menu in your custom menu details and update 
the title or shortcut key in the Title or Shortcut Key 
fields. 
You can only change the title of a main menu. If a main 
menu contains other submenus, you cannot rename the 
submenus within the main menu without first copying 
the main menu. 
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To... Do this... 
change the title or shortcut to a main menu 
or a window within a main menu in your 
custom menu 

 
 

select the menu or window in your custom menu details 
and update the title or key in the Title or Shortcut Key 
field. 
The system displays a warning message indicating that 
you cannot change the contents of a main menu. Click 
OK, to rename the menu, which creates your own 
version of the menu, and update the title or shortcut key.  
Your versions of menus are indicated with a folder   
icon. 

remove a submenu or a window from a 
main menu 
 

select the menu or window in your custom menu details 
you want to remove and click Remove. 
The system displays a warning message indicating that 
you cannot change the contents of a main menu. Click 
OK, to rename the menu. You can remove any submenu 
or window from your version of the menu.   
Your versions of menus are indicated with a folder   
icon. 

4. From the File menu, select Save to save your custom menu. That menu is now available for 
selection to add to other custom menus in the Main Menus list.  
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Adding Non-Standard Menu Options to Custom Menus 
As you create custom menus, you can add G/L reports, Report Writer reports, mass loads, user-defined 
screens, and custom subroutines to any menu. Using Menu Maintenance, the system validates the 
additional menu options you are adding against the reports, mass loads, and user-defined screens 
available.  

To add a non-standard menu option to a custom menu: 

1. From the System > System Files > User Control menu, select Menu Maintenance to display 
the Menu Maintenance window. 

2. On the right side of the menu, select the menu ID you want to edit in the Menu field, or click 
New to create a new menu.  

3. Select the menu or window above which you want to add the non-standard menu option.  

You can also insert the menu anywhere and use the Move Up and Move Down buttons to place 
the menu option in the correct place. 

4. Select Additional and then select the type of option you want to add for each option, complete 
the menu information in the dialog box that displays, and click OK to add the option to your 
custom menu. 

For each menu item, enter a title in the Title field that identifies the menu option in and a shortcut 
key used with the Alt key to access the menu using the keyboard in the Shortcut Key field. The 
Shortcut Key field displays only the keys available within the menu to which you are adding the 
option. 

Menu Option Description 
G/L Report Adds a menu option for any general ledger report available to you that was 

created using the G/L Report Generator.  
General ledger reports start with GL-. For example,  
GL-EXPENSE. The list in the GL Report Name field provides all the general 
ledger reports available to you. 

Report Writer Adds a menu option for any report you have created using the Report Writer. 
Report writer reports start with LREP-. For example,  
LREP-ABC.CODES. The list in the Report Writer Name field provides all the 
report writer reports available to you. 

User-Defined 
Screen 

Adds a menu option for any user-defined screen in your system. 
User-defined screens start with FORM-. For example,  
FORM-USERZ.SCREEN. 

Mass Load Adds a menu option for any load program you have created using Mass Load. 
Mass loads start with LREP-. For example,  
LREP-ABC.CODES. 

Advanced Menu Adds a menu option for any subroutine you want to add to your menu. For 
example, if you have a custom programming on your site, you can add the 
subroutine that calls the custom program to your menu. The system searches all 
available menus.  

5. From the File menu, select Save to save your custom menu.  
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Creating User-Specific Custom Menus 
A user-specific custom menu is one that only a designated user can access. For example, if you have one 
user who is responsible for a particular administrative task, you can create a menu for the application used 
to perform that task that only that user can access. 

Create user-specific custom menus by giving the menu a name using the ID of the user for whom it is 
being created. 

• A user-specific menu name consists of an ampersand (&), the user ID of the designated user, and 
another ampersand.  

For example, for a user whose ID is JDOE, name a user-specific menu &JDOE&. 

• If you need more than one user-specific menu for this user, you can add characters between the 
user ID and the second ampersand.  

For example, you can have two user-specific menus named &JDOE01& and &JDOER02&. 

Note: Although the extra characters in this example are two numbers, you can append up 
to nine alphanumeric characters to a user ID. 

After creating a user-specific custom menu, you need to assign it to a user-defined menu. 
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Viewing and Updating Advanced Menu Properties 
Each menu item you add contains properties that the system finds and attaches for you. You can view and 
update these properties, as needed. You can also use these properties to create a menu option from 
scratch, without pulling it from a source menu, or when you are adding a custom program or subroutine to 
a menu.  

To view and update advanced menu properties: 

1. From the System > System Files > User Control menu, select Menu Maintenance to display 
the Menu Maintenance window. 

2. On the right side of the window, select the menu ID you want to edit in the Menu field, or click 
New to create a new menu.  

3. In your custom menu details, select the item you want to view or update and click Advanced. 
The Advanced window displays the following information for the menu: 

Field Description 
Eterm Title The menu title, as it displays in Eterm interface. 

Eterm Shortcut Key The menu's shortcut key (Alt + this key) used in the Eterm interface. 

Solar Title The menu title, as it displays in the Solar interface. 

Solar Shortcut Key The menu's shortcut key (Alt + this key) used in the Solar interface. 

Eterm Program Name The program name, such as AP.PREVIEW.QUEUE to call the program in 
Eterm.  For a menu option to be available in Eterm, it must have an Eterm 
program name. 

Eterm Passer The value to pass to the program that identifies which window to display 
for this menu option.  
For example, the same program runs report writer and mass load. Menu 
selections that display the report writer version of the Report Writer/Mass 
Load Design window use the passer value R. Menu selections that display 
the mass load version of the Report Writer/Mass Load Design window 
use the passer value M. 

Java Package and 
Java Class 

For Solar menus, the Java program to display from the menu. Together, 
the Java Package and the Java Class create the program name. 

 
Anything after the last period (.) in the program name is the Java class. 
For a menu option to be available in Solar, it must have a Java Package 
and Java Class. 
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Field Description 
Java Passer The value to pass to the program that identifies which window to display 

for this menu option.  
For example, the same program runs report writer and mass load. Menu 
selections that display the report writer version of the Report Writer/Mass 
Load Design window use the passer value R. Menu selections that display 
the mass load version of the Report Writer/Mass Load Design window 
use the passer value M. 
For menus that call a user-defined window, set this field to the 
UD.FORM ID for the window. 

Auth Product If you are adding a companion product, enter the authorization code for 
the product. If you are not authorized for this companion, this menu 
option does not display on the menu. 

Shown Where The user interface the program is available in on the menu: Eterm, Solar, 
or Both.  

4. Click OK to close the window. 

5. From the File menu, select Save to save your custom menu. That menu is now available for 
selection to add to other custom menus in the Main Menus list.  
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Assigning Custom Menus 
Customizing standard Eclipse menus includes one or more two-step processes. After you create a custom 
menu, you need to assign it. When you customize a submenu, then you also need to customize the menu 
that links to it. 

Custom Main Menus 
After you create a custom main menu, you need to assign it as the root menu for the appropriate users. For 
example, you have a group of users who should not have access to the A/R and A/P menus. Create a user-
defined version of the MAIN menu that excludes the A/R and A/P menus, and then assign the user-
defined menu as the root menu to these users. 

Note: You must be assigned the USER.MAINT.ALLOWED authorization key to assign 
a user's root menu. 

To assign a root menu to a user: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter the user whose record you want to update. 

3. In the Root Menu field, enter the name of the main menu to assign to this user. 

4. Save the user record and exit the window. 

Custom Submenus 
If you create a custom submenu, you need to assign it to a menu to which the users you created it for have 
access. For example, your company does not use material data safety sheets (MSDS) and you want to 
remove this menu option from the FILES menu for all users.  

To give a user access to a custom submenu: 

1. Create a copy of the FILES menu and remove the MSDS program from the menu. 

2. Create a copy of the MAIN menu and change the link to the standard FILES menu to point to 
your copy of the FILES menu.  

3. Assign your copy of the MAIN menu as the root menu for your users as described above. 

User-specific Custom Menus 
The last item on the standard SYSTEM menu is a link to the User Custom Menu. If you create user-
specific custom menus, each user can access their user-specific menu by clicking the User Custom Menu 
link.  
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Custom Report Drivers Overview 
Typically, Epicor personnel create custom reports for your site and provide a custom report driver 
window for you. However, if you are trained to create subroutine and custom programming for your site, 
you can use the User Defined Solar Window Setup window to create a user interface window for your 
users to select how they want to run a report that is custom to your site. 

Important: If you are unfamiliar with how to setup a custom subroutine for your site, contact 
your Epicor sales person for information about your custom needs. 

Complete the following steps to create a custom report driver: 

• Create the subroutine that searches the database and generates the report content.  

• Create the custom report driver window that users use to enter the parameters for which to run the 
report. 

• Add the custom report driver window to a Solar Eclipse menu. 

For information about the components that comprise a custom driver window, see Custom Report Driver 
Components. 
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Creating Custom Report Driver Windows 
Create a custom report driver to a provide a window available from a Solar Eclipse menu. Users can use 
the window to select the content to include in a report that is custom to your site. Using a custom report 
driver allows users to select how they want to run the report, similar to how they run a standard system 
report, such as the A/R Aging Report, without having to know the system data structure. 

Important: You must have the User Defined Solar Window Setup window as part of your user 
menus, and have the subroutine created that gathers the data for the report prior to 
setting up the custom report driver window. If you are unfamiliar with how to 
setup a custom subroutine for your site, contact your inside sales person for 
information about your custom needs. 

To create a custom report driver window: 

1. From the System > System Programming > User Defined Functions menu, select User 
Defined Solar Window Setup to display the User Defined Solar Window Setup window. 

2. In the Window ID field, either enter the ID of an existing window you want to edit or click the 
New button next to the field and enter a new window ID. Window IDs cannot contain spaces and 
must be unique. 

3. Use the Input Definitions area to define the fields you want to include in the report driver.  

Define a single input type per line in the table. The fields display in the window from top to 
bottom in the order they are listed in the table. Select a row and use the Move Up and Move 
Down buttons to move the rows to be in the correct order.  

Place the Separator input type between sections of your windows for easier readability. 

For each input type you add, provide the following information: 

Field Description 
Input Type Select the type of field you want to define, such as a branch input field or a date 

input field. For a description of the input types and the options associated with 
each, see Custom Report Driver Components. 

Prompt Enter the field name that displays to identify the type of data the user should 
enter. For example, if you are defining a date range, for the first date field, enter 
Start Date as the field name.  

Required Select this check box if users must enter a value or make a selection in the field 
prior to running the report. For example, if you are defining a branch input field, 
you might require that at least one branch is entered prior to running the report. 

Length Enter the maximum number of characters allowed in the field.  
This field applies to Branch, Date, Number, and String input types. 

Validation Select the area of the system to verify entries against. For example, select 
Customer to check that the entry in the field matches a customer in Customer 
Maintenance. For a list of validation types, see Custom Report Driver 
Components. 
This field applies to the String input type. 
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Field Description 
Conversion Select what the system converts the value entered in the field to after it 

completes the validation, such as the Description from Buy Line Maintenance. 
For a list of conversion types, see Custom Report Driver Components.  
This field applies to the String input type. 

Decimals Enter the number of decimal places the field accepts. For example, if you are 
setting up a number field that represents a dollar amount, enter 2 to indicate that 
the field can accept a number such as $100.01. 
This field applies to the Number input type. 

Options Some input types contain different options for the field. For example, for a 
branch input field you can select whether a user can enter any branch, or only 
those they are authorized to view. The options vary for each field's function. 
Review the options available for each input type and make your selections as 
necessary. For more information, see Custom Report Driver Components. 

Multi-Allowed Select this check box if multiple inputs for the field are accepted. For example, 
if you are defining a branch input field, select this check box if the user can 
select to run the custom report for more than one branch at a time.  
This field applies to Branch and String input types. If you are defining a branch 
input field, the user is allowed to enter multiple branches or territories. If you 
are defining a string input field, the field in the report driver includes a Multiple 
button next to the field. 

Additional Data For the Radio and Check Box Group input types, use this field to indicate the 
names of the options included in those groups. The first option in the list is the 
default selection. For more information and examples, see Custom Report 
Driver Components. 

Field Save ID This is a free-form field that allows you to specify an ID. For example, a good 
ID for a Customer field might be &rdquor;CUS.ID”. If this field is populated, 
then the value the user enters this field on the report driver is saved when the 
user runs the report. The next time the user opens the driver window, the last 
value they had in the field automatically populates. 
The entry in this field must be all uppercase and can contain no spaces. 
This field applies only to input fields, not to check boxes or radio buttons. 

Parameter Name Enter the parameter name from the parameter listing of the subroutine you are 
using for this custom report driver.  

4. In the Window Title field, enter the name you want to display at the top of the custom driver you 
are creating. 

5. In the Phantom Routine field, enter or select the subroutine you created that runs for the report.  

6. In the Selection Type field, choose which selection menu type you want to add to the driver 
window. The Selection menu is standard on nearly all Solar Eclipse reports, and allows a user to 
narrow the information contained in the report. 

• None - Does not add a Selection menu to the report driver. 

• Sales - Includes a Selection menu with selection criteria that is specific to sales orders, such as 
Credit Card Types and Customer PO#. See the Selection menu in the Open Sales Orders 
Report for an example. 
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• Purchase - Includes a Selection menu with selection criteria that is specific to purchase orders, 
such as Pay To Vendor Types and Payment Terms. See the Selection menu in the Open 
P/Os Report for an example. 

• Payable - Includes a Selection menu with selection criteria that is specific to accounting and 
payables, such as Invoice ID and Report Currency. See the Selection menu in the Check 
Register Report for an example. 

7. In the Report Options area, select whether users can print the report, send it to their hold file, or 
transmit it using e-mail or by fax.  

8. From the Tools menu, select Generate Framework Code to get the basic code to start building 
the routine for the report. You can copy all to the computer clip board and paste it in your 
program.  

9. Save your report driver and add it to a Solar Eclipse menu. 
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Custom Report Driver Components 
Each custom report driver that you create consists of the following components: 

• Window ID - A unique identifier for the window that you can then use to add it to a Solar Eclipse 
menu in Menu Maintenance. 

• Input Definitions - The fields and their options to include in the driver window, such as date 
ranges and customer names. For more information about the input types you can add and the 
options that apply to each, see Input Types and Options below. 

• Window Title - The name that displays at the top of the window. For example, the title of the 
window you use to define your custom report drivers is "User Defined Solar Window Setup." 

• Report Options - The subroutine written to gather the report information as specified using the 
custom driver window, along with the options to print, e-mail, fax, or send a report to the Hold file. 
The subroutine is something that you, or Eclipse personnel write that is specific to your needs. 

Input Types and Options 
Each input type, or field, you define for a custom report driver has a unique set of potential validations, 
conversions, and options you can define. Use the following table to determine what you can set for each 
input type. For information about including input fields in a custom report driver window, see Creating 
Custom Report Driver Windows. 

Input  
Type 

Description Validation, Conversion, Options, and Additional Data 

Branch Adds an input field 
that validates 
against the 
available branches 
defined in your 
system. 

In the Options field, select one of the following:  
• All Branches - The user can enter any branch that is defined in your 

system. 
• Authorized Branches - The user can only enter branches to which 

they are authorized in User Maintenance. This is the default. 

Date Adds a date input 
field that accepts 
dates in the 
standard 
mm/dd/yyyy 
format. 

In the Options field, select one of the following: 
• None - Allows any valid calendar date. This is the default. 
• Variable Dating - Allows any valid calendar date, and also allows 

variable dating in the date field so the date can change as needed for 
scheduling purposes. 

Number Adds a field that 
accepts numeric 
data, such as for 
dollar amounts. 

In the Options field, select one of the following:  
• None - Allows only positive numbers with the number of decimal 

places defined in the Decimals field. This is the default. 
• Allow Negative - Allows positive and negative numbers with the 

number of decimal places defined in the Decimals field. 
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Input  
Type 

Description Validation, Conversion, Options, and Additional Data 

String Adds a text string 
field, such as to 
enter a buy line, 
price line, 
customer, or 
vendor. 

In the Validation field, select what the system checks the text entered 
against to ensure it is a valid entry:  
• Customer - Validates that the text entered matches a customer in 

Customer Maintenance. 
• Vendor - Validates that the text entered matches a vendor in Vendor 

Maintenance. 
• Product - Validates that the text entered matches a product in 

Product Maintenance.  
• Price Line - Validates that the text entered matches a price line 

defined in Price Line Maintenance. 
• Buy Line - Validates that the text entered matches a buy line defined 

in Buy Line Maintenance. 
• Sell Group - Validates that the text entered matches a sell group 

defined in Buy/Sell Group Maintenance. 
• Buy Group  - Validates that the text entered matches a buy group 

defined in Buy/Sell Group Maintenance. 
• User  - Validates that the text entered matches a user ID defined in 

User Maintenance. 
• Custom - Validates that the text entered matches the custom code 

validation you provide. For example, D:, Option One, Option 2 
validates against a predefined list of options. 

In the Conversion field, select what the system converts the entered 
value to in the corresponding string field.: 
• Entity Desc - Converts the text entered to the customer or vendor 

name as defined in Customer or Vendor Maintenance. 
• Product Desc - Converts the text entered to the product description 

as defined in Product Maintenance. 
• Price Line Desc - Converts the text entered to the description for a 

price line ID as defined in Price Line Maintenance. 
• Buy Line Desc - Converts the text entered to the description for a 

buy line ID as defined in Buy Line Maintenance. 
• User Name - Converts the text entered to the name as defined in 

User Maintenance. 
• Upper Case - Converts the text entered to all UPPERCASE letter. 
• Lower Case - Converts the text entered to all lowercase letters.  
• Custom - Converts the text entered to the custom code validation 

you provide.  
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Input  
Type 

Description Validation, Conversion, Options, and Additional Data 

Yes/No Adds a check box 
field, that if 
selected is set to 
Yes, and if 
deselected is set to 
No. Use this field 
for a single check 
box that is not part 
of a group. Use the 
Check Box Group 
input type to set up 
a series of check 
boxes that are 
grouped together 
under an area 
heading. 

No additional settings apply to Yes/No fields. 

Check Box 
Group 

Adds a group of 
check boxes 
contained within a 
border with a title 
equal to what you 
enter in the 
Prompt field. 

In the Additional Data field, enter the names of the check boxes you 
want to include in the group of check boxes, separated by commas. 
The first option in the list is the default selection. Example.  

 

Radio Adds a group of 
radio buttons, 
where a user can 
select only one 
option, contained 
within a border 
with a title equal to 
what you enter in 
the Prompt field. 

In the Additional Data field, enter the names of the radio buttons you 
want to include in the group of radio buttons, separated by commas. 
The first option in the list is the default selection. Example. 

 

Include/ 
Exclude 

Adds a field that 
contains the 
options Include or 
Exclude to include 
or exclude a type of 
data from the 
report. Enter the 
field name in the 
Prompt field. 

In the Options field, select one of the following: 
• None - Contains the Include and Exclude options for the field. The 

field on the report driver window displays with the name in the 
Prompt field with Include/Exclude in parentheses. This is the 
default. 

• Add "Only" Option - Adds an Only option, so users can select to 
include only the item defined in the field. The field on the report 
driver window displays with the name in the Prompt field with 
Include/Exclude/Only in parentheses. 
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Input  
Type 

Description Validation, Conversion, Options, and Additional Data 

Separator Adds a line to 
separate portions of 
the window. You 
cannot have a 
separator as the 
first field in the 
window. 
Use separators to 
group like fields on 
a window for easier 
user entry. 

No additional settings apply to separators.  
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Adding Custom Report Drivers to Solar Eclipse Menus 
After you create a custom report driver, add it to a Solar Eclipse menu and then assign that menu to any 
users that you want to have access to the report driver.  

The menu you create is assigned as the user's main menu in Solar. Ensure that you have also included the 
other menu options that you want users to have access to. 

Note: Users must exit Solar and log in again to see the new menu options. 

To add a custom report driver to a Solar Eclipse menu: 

1. From the System > System Files > User Control menu, select Menu Maintenance to display 
the Menu Maintenance window. 

2. Display an existing menu to which you want to add the report driver, or create a new menu. 

3. Click Add Solar Report, enter the ID of the report driver you created in Creating Custom Report 
Driver Windows, and click OK. 

4. Enter the title of the report driver the way you want it to display on the menu and click OK.  

The Advanced Properties window for the menu item displays with the following information 
needed to add the report driver to the menu, for example, the JavaClass 
UserDefinedReportDriver. 

5. Click OK to return to Menu Maintenance. 

6. Save your menu and exit the window. 

7. From the System > System Files > User Control menu, select User Maintenance and display 
the user to which you want to add the menu you just created. 

8. From the Maintenance menu, select Solar Eclipse Options to display the Solar Eclipse User 
Maintenance window. 

9. In the Solar Main Menu field, enter the menu to which you added the custom report driver.  

10. Save your changes and save the user record. 
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User-Defined Functions Overview 
Customize your system with user-defined functions, without affecting the integrity of the standard screens 
or associated files.  

By defining subroutines and formats, you can customize the following: 

• Printing labels for shipping, receiving, transfers, products, and customer- or vendor-specific part 
numbers. Once labels are customized to your company's needs, you can print the correct labels 
from the applications. 

• Text files that you want to upload into the application. You can integrate data, such as price 
updates, into the application by uploading the text file into the spooler and then into the 
corresponding application. 

• Files that you want to upload into Sales Order Entry. If your outside sales people place orders on a 
portable PC, they can upload the files into the SOE Body screen directly from the files on their PC.  

• User-defined screens that you can use to enhance applications for your company. 

• Order entry views if the standard views do not meet all of your company's needs. 

• Views for any window whose standard views do not meet your needs.  

• Views for any tables whose standard views do not meet your business tasks. 



Rel. 8.7.4 Application Maintenance 

© 2012  Epicor Software Corporation. All rights reserved. 71 

Maintaining User-Defined Labels 
Use subroutines to produce the special labels printed for your company's applications.  

For each application area, you need to identify the associated label and document subroutines. Once 
defined, you can print the defined labels from the application areas. The following table shows each 
application area and how to display the labels defined for that application:  

To display label options for... Use the...  
Shipping labels in SOE Label hot key on the SOE Body screen. 

Receiving labels in POE Label hot key on the POE Body screen. 

Transfer labels in TOE Label hot key on the TOE Body screen. 

Product labels in Product Label 
Printing 

F10 key in the Label Format field on the Product Label 
Printing screen. 

Customer/Vendor Specific Part 
Number labels 

Print Label hot key on the Customer/Vendor Specific Part 
Numbers screen. 

Use the User Defined [application name] Label Format Maintenance screen to define the label 
subroutines associated with each application. The title of the screen varies for each application, but the 
fields and hot keys are the same. 

To maintain user-defined labels: 

1. Display the User-Defined Documents menu in one of the following ways: 

• From the System > System Programming menu, select User Defined Functions. 

• From the Tools menu, select User Defined Documents. 

2. From this menu, select one of the following applications to display the label format maintenance 
screen: 

• User Defined Shipping Documents 

• User Defined Receiving Documents 

• User Defined Transfer Documents 

• User Defined Product Documents 

• User Defined Customer Documents 

• User Defined PN Xref Documents 

You must be assigned the SYSTEM.PROGRAMMING authorization key to use these label 
format maintenance programs. 

Note: If prompted, log on to the character-based system. 

3. In the Label Format Title field, enter an identifying name for the label format. 

4. In the Subroutine Name field, enter OIDIMAGING.OUT, the subroutine that prints the label 
document.  

5. In the Typ field, enter one of the following subroutine types:  
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• IM - Item specific, multi-call. 

• IS - Item specific, single-call. 

• OM - Order specific, multi-call. 

• OS - Order specific, single-call. 

• NO - No auto looping. 

The writer of the subroutine can tell you which type to assign. 

6. In the Form field, press F10 and select the form on which the designated label prints, such as 
LABEL. 

Note: The system determines which printer has this form loaded. Define forms on the 
Forms Definition screen. 

7. Press Esc to save the information and exit the screen. 

Note: Do not use the DDE Subroutine hot key. This key is for internal use by Eclipse 
personnel only. 
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Maintaining User-Defined Upload Formats 
You can upload text files to the spooler so that multiple applications can import them.  

For example, you have just received a text file of price updates for your plumbing products. Upload this 
text file into the spooler, and then use the Price Updating function to update the prices for all of your 
plumbing supplies.  

For each type of text file you want to upload, you need to create an upload format, which identifies the 
subroutine the system uses to format the data and perform the upload. 

To maintain user-defined upload formats: 

1. Display the User Defined Upload Format Maintenance screen in one of the following ways: 

• From the System > System Programming > User Defined Functions menu, select User 
Defined Upload Processing. 

• From the Tools > User Defined Documents menu, select User Defined Upload Processing. 

Note: If prompted, log on to the character-based system. 

2. In the Label Format Title field, enter a name that identifies the data to upload.  

3. In the Subroutine Name field, enter the name of the subroutine that uploads the data. 

Note: The Typ and Form fields do not apply to upload processing, and the DDE 
Subroutine hot key is for internal use by Eclipse personnel only. 

4. To limit subroutine access to users assigned a designated authorization key, use the 
Authorization hot key.  

At the prompt, select the authorization key which must be assigned to the user. 

5. Press Esc to save the information and exit the screen. 
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Maintaining User-Defined OE Import Formats 
From the SOE Body screen, you can import an order's line item information from a data file on your PC. 
Your outside salespeople can use this feature to enter an order on a portable device and then import all the 
quantity and product information directly into a sales order. 

Before using this feature, you need to set up the system to work with your data files. For each type of text 
file you want to upload into Sales Order Entry, identify the subroutine the system uses to format the data 
and perform the import.  

To maintain user-defined OE import formats: 

1. Display the User Defined Bid Upload Format Maintenance screen in one of the following ways: 

• From the System > System Programming > User Defined Functions menu, select User 
Defined OE Import. 

• From the Tools > User Defined Documents menu, select User Defined OE Import. 

Note: If prompted, log on to the character-based system. 

2. In the Label Format Title field, enter a name that identifies the data to import.  

This name displays in the F10 options list for the File Format field on the Order Entry Data 
Import screen. 

3. In the Subroutine Name field, enter the name of the subroutine that imports the data. 

Note: The Typ and Form fields do not apply to importing data, and the DDE 
Subroutine hot key is for internal use by Eclipse personnel only. 

4. To limit subroutine access to users assigned a designated authorization key, use the 
Authorization hot key.  

At the prompt, select the authorization key, which must be assigned to the user. 

5. Press Esc to save the information and exit the screen. 
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User-Defined Screens through Eterm 
The system includes utilities you can use to develop custom user-defined files and screens. You can 
create user-defined screens for entering information into a standard file or a user-defined file. 

Note: You must attend a class or receive training before you can create user-defined 
screens in the character-based system. Visit the Eclipse Customer Support 
Website for further information. 

• You can create user-defined screens and append them to standard screens without affecting the 
integrity of the original screen or associated files.  

• You can also create stand-alone user-defined screens to use with user-defined files, such as report 
drivers. 

• If you have created and attached a user-defined screen in the character-based system, you can 
display and use a Windows version of that screen in Solar Eclipse. 

Not all facets of a screen developed in the character-based system work in Solar Eclipse due to 
differences in the interface technology. Fields could behave differently in Solar Eclipse than they 
due in the character-based system.  

Test any screens you create in the character-based system on an individual basis. 
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Adding User-Defined Table Columns 
In order to give you better ability to configure Eclipse to best meet your needs on a daily business in how 
you do your work, you can add any data represented by an Eclipse Dictionary to tables in Solar Eclipse 
that have a View Manager. The View Manager provides quick access to all views which you are 
authorized to see and is readily available throughout Solar Eclipse on tables such as the Inventory History 
Ledger, A/R Inquiry, Sales Order Entry, Suggested P/O Queue, and the P/O Variance Queue. 

Note: You can assign any views you create to other users, as needed. Users may need to 
close the window or log off and back in to Solar Eclipse to see the change and use 
the new views assigned to them. 

To add a user-defined table column: 

1. Display the window with the table to which you want to add a column. 

2. Click the View Manager icon   and select User Defined View Maintenance to display the User 
Defined View Maintenance window. 

3. From File menu, select User Defined Table Columns to display the User Defined Table 
Columns window. 

4. Complete the fields, as needed. Required fields are marked with an asterisk. 

Field Description 
Column ID A free-form field to label your column information. This ID is for 

your reference only. We highly recommend following a standard 
naming convention so you can locate your user-defined column 
descriptions later. 

Column Name* The actual label for he column to display in the table. 

Key Column* The identifier, or key, for the information you get from the file 
selected, such as Warehouse #. This key is an exact match to the 
record ID in the file from which you are getting the additional field 
data. For example, if the 4-digit branch is in an existing view, you 
can use that as the key to the Territory file to gain access to the 
dictionaries from the Territory file. 

Universe File The file in the system from which you want to pull information, 
such as TERRITORY. 
Mutually exclusive with Pick Program and available only if the 
Column Data Source is set to Universe File.  

File Dictionary The item within the file that you want to populate on the table, such 
as TERRITORY_DESC, within the Universe file selected. 

Pick Program Mutually exclusive with Universe File and available only if the 
Column Data Source is set to Pick Program. 

5. In the Column Data Source area, select Universe File or PICK Program to tell the system 
which kind of file you are using for the column data. For example: 
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5. Save your changes and exit the window to apply your new column. For example: 
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Appending User-Defined Fields to Screens 
Based on your business needs and the tasks you need to perform in various windows, you may find you 
would be more efficient if you could add one or two fields to an existing window. You can create user-
defined fields or pull information for a specific field you want to add and append them to standard 
windows without affecting the integrity of the original window or its associated files. 

You can append, or attach, fields to the right, left, or bottom of the current window. You cannot append 
fields without creating the fields or screen first using the User-Defined Screen Designer. 

Before adding fields, consider how much space exists on the current window. The fields you add append 
to the bottom of the window and the system may truncate other parts of the window if there is a lot of 
information to display, such as the Vendor Maintenance window. 

Note: As of Release 8.7.2, this functionality is available only for Customer Maintenance, 
Product Maintenance, Vendor Maintenance, and Branch Maintenance.  

To append a user-defined field: 

1. Display the window to which you want to append additional fields. 

2. From the User Tools menu, select Attach User Defined Screens to display the User Defined 
Screen Attachments. 

3. Select the area you want to add the fields to: 

• Left User Defined Screen - Appends fields to the left-hand side of the window. 

• Right User Defined Screen - Appends fields to the right-hand side of the window. 

• Bottom User Defined Screen - Appends fields to the bottom of the window below all standard 
fields. 

Note: There may be pre-defined buffers around the fields you add because they are 
coming from Eterm-defined screens. This can affect how your standard fields 
display and how the window resizes. 

4. In the UD Screen ID field, enter the identifier for the fields you want to add, such as 
HAJO.BR.SOLAR. 

5. In the Screen Key field, select the data type to populate in the field, such as ACTIVE. This 
selection is used to pull data in from the file used for the screen you are attaching.  

6. Click OK to save your changes and exit the window. 

For example: 
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User-Defined Views Overview 
Throughout the system, many windows display with tables that contain various information. From these 
windows, you often have access to different views to see different data. You might find that you or your 
users need to see some data from one view and some from others, or that you want to only see a subset of 
the data in one view. 

Note: You cannot create user-defined views in the Body of a sales, purchase, or transfer 
order. You also cannot create a user-defined view in the Order View All Totals 
window or in Quick Sell Matrix Maintenance. 

To give you access to information you need in a window, create a user-defined view that contains the 
columns of data that you use the most in that window. 

Using user-defined views allows you to do the following: 

• Create a view as that contains the information you need. You can choose to base your view on an 
existing Eclipse view.  

• Save your view as the default, so it displays each time you enter the window.  

• Assigning individual users and user groups to the view. 

• Create view templates with multiple views that you can assign to other users.  

• Still access system-defined views.  

The following authorization keys are required for working with user-defined views: 

• SOLAR.UD.VIEW.CREATE 

• SOLAR.UD.VIEW.ASSIGN 

Note: If a user does not have access a column within a window, the data in that field 
within the view is blank for that user. 
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Creating User-Defined Views 
Throughout the system, many windows display with tables that contain various information. From these 
windows, you often have access to different views to see different data. You might find that you or your 
users need to see some data from one view and some from others, or that you want to only see a subset of 
the data in one view.  

Note: Users may need to close the window or log off and back in to Solar Eclipse to see 
the change and use the new views assigned to them. 

If you are assigned the SOLAR.UD.VIEW.CREATE authorization key, you can create a user-defined 
view in any window that contains views. The view you create is specific to the window in which you 
create it.  

To assign a user-defined view to other users, create a template that contains the view and assign the 
template to the user. To add a column outside the standard column views, see Adding user-Defined Table 
Columns. 

Note: If a user does not have access a column within a window, the data in that field 
within the view is blank for that user. 

To create a user-defined view: 

1. From any window that has different views, click the icon in the upper fight corner of the table and 
select User-Defined View Maintenance from the list.  

You can also access User-Defined View Maintenance by selecting User-Defined View 
Maintenance from the menu that you use to change views in the window..  

2. In the View ID field, click New, enter a short ID that identifies the view, and click OK. For 
example, ACCT.SUPERVISOR. 

Note: View IDs cannot contain special characters such as *, (, ), or &.  

3. In the View Description field, enter a title for the view. This is the title that displays in the 
Change View menu when you complete the view.  

4. To base your view on an existing view for the window, select File > Start with Eclipse view and 
select the view that you want to start with. The system populates the On Table and Not Used 
lists with the columns that are included in that view.  

Note: Some windows have columns that are required in each view. Required columns are 
highlighted in red to indicate that you must include them in the view. 

5. Select the column names and use the Add and Remove buttons as appropriate to list all the 
columns you want to include in the view in the On Table list.  

6. Select a column in the On Table list, and use the Move Up and Move Down buttons to position 
the columns in the correct order.  

The columns display from left to right in the view as they are listed from top to bottom in the list.  

7. Save your changes and exit the window. Your changes are available immediately. 
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Assigning Users to User-Defined Views  
If you create a view that could be useful to other users, you can assign that view to an individual user, a 
group of users, or to a template. If you have a set of views for various windows in the system, use a 
template and assign all the appropriate views to that template. For more information, see Creating and 
Assigning User-Defined View Templates to Users.  If you want to share a view with select users that are 
not part of a template, you can assign the view to an individual user, or a group of users. 

You must be assigned the SOLAR.UD.VIEW.ASSIGN authorization key to create view templates and 
add views to templates.  

To assign users to user-defined views: 

1. From any window that has different views, click the icon in the upper right corner of the table and 
select User-Defined View Maintenance from the list.  

You can also access User-Defined View Maintenance by selecting User-Defined View 
Maintenance from the menu that you use to change views in the window. 

2. From the Templates menu, select Assign Users to View to display the User-Defined View 
Customization - Assign Users to View window.  

3. In the Name field, enter the system IDs of each user or user group to which you want to assign 
the view.  

4. Click OK to return to the User-Defined View Maintenance window.  

5. Save your changes and exit the window. 
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Opening User-Defined Views 
User-defined views are accessible from the same menu in a window that you would use to change your 
view. This menu is often a View menu or a Change View menu. User-defined views are listed below the 
standard views defined for the window.  

Note: Users may need to close the window or log off and back in to Solar Eclipse to see 
the change and use the new views assigned to them. 

All users can view user-defined views that they have been assigned. However, you must have the 
SOLAR.UD.VIEW.CREATE authorization key to create your own views. You must have the 
SOLAR.UD.VIEW.ASSIGN authorization key to edit views that were assigned to you through a 
template.  

To open a user-defined view: 

1. From any window that has views, select the menu that you use to access different views, such as 
View > Change View or Change View, and select the user-defined view from the list.  

You can also open the view by clicking the icon in the upper right side of the table and selecting 
the view from the list. 

2. To save a user-defined view as your default view for a window, right-click in the heading row of 
the table and select Save Settings.  

If you have saved a user-defined view as your default setting, and that view is no longer 
available, the next time you access the window, the system uses the default system view.  
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Creating and Assigning User-Defined View Templates to 
Users 
Much like custom toolbars, you can define a view for a window and assign that view to a template. You 
can then assign that template to a set of users so they all have access to the same view. For example, at 
your site you might decide that you want all users of a particular window to have access to a set of user-
defined views. 

Create a template to include all the views for various windows to assign to your users. You can then 
assign users the template and they receive all the views for different windows at once. Templates save 
you time in setting up your users with what they need in each window. 

You must be assigned the SOLAR.UD.VIEW.ASSIGN authorization key to create and assign templates 
to users, however, any user can be assigned to a template. 

To assign a view to a user without creating a template, see Assigning User-Defined Views to Users.  

Note: Users may need to close the window or log off and back in to Solar Eclipse to see 
the change and use the new views assigned to them. 

To create and assign user-defined view templates to a user:  

1. From any window that has different views, click the icon in the upper right corner of the table and 
select User-Defined View Maintenance from the list.  

You can also access User-Defined View Maintenance by selecting User-Defined View 
Maintenance from the menu that you use to change views in the window. 

2. From the Templates menu, select Create Template.  

3. Enter the name of the template and click OK. For example, if you are creating a template of 
views for your accounting supervisors, name the view ACCT.SUPERVISOR. 

4. From the Templates menu, click Assign Users To Template and select the template you created 
in step 3.  

5. In the User field, enter the system IDs of the users to which you want to assign to the template. 
Each user that is assigned to the template can see the views that you add to the template.  

6. Click OK to return to the User-Defined View Maintenance window. 

7. Assign a view to the template. 
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Assigning Templates to User-Defined Views 
Much like custom toolbars, you can define a view for a window and assign that view to a template. You 
can then assign that template to a set of users so they all have access to the same view. For example, at 
your site, you might decide that you want all users of a particular window to have access to a set of user-
defined views.  

You must be assigned the SOLAR.UD.VIEW.ASSIGN authorization key to create view templates and 
add views to templates.  

Note: You can assign a view to multiple templates. Users may need to close the window 
or log off and back in to Solar Eclipse to see the change and use the new views 
assigned to them. 

To assign a view to a user without creating a template, see Assigning User-Defined Views to Users. 

To assign a user-defined view to a template:  

1. From any window that has different views, click the icon in the upper right corner of the table and 
select User-Defined View Maintenance from the list.  

You can also access User-Defined View Maintenance by selecting User-Defined View 
Maintenance from the menu that you use to change views in the window..  

2. Create and assign users to a template. For more information, see Creating and Assigning User-
Defined View Templates to Users. 

3. From the Templates menu, select Assign Templates to View to display a list of all the user-
defined view templates in the system. 

4. Select the templates to which you want to add the view and click OK. You can add a view to 
multiple templates.  

The User-Defined View Maintenance window now displays the number of templates to which the 
view is assigned in the bottom left corner.  

5. Save your changes and exit the window. 

The next time users assigned to the template access the window, the new view is available to 
them in the Change View menu, or by clicking the icon above the table. 
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Creating and Editing User-Defined F9 Help in the Character-
Based System 
You can create your own F9 help for fields in the character-based system. For example, you can enter 
user-defined instructions that are specific to your company's operations.  

If you have created user-defined help for a field, the system displays this help when you press F9 in that 
field. In the screen title, the asterisk (*) preceding and "User version" following the field ID indicate that 
you are viewing user-defined help. Use the Eclipse Version hot key to display the system help for this 
field and the User Version hot key to re-display the user-defined help. 

Users must be assigned the HELP.EDIT authorization key to create user-defined F9 help. 

To create or edit user-defined F9 help: 

1. Position the cursor on the field for which you want to create user-defined help and press Shift-F9. 

The system displays the user-defined version of the help, if one already exists. Otherwise, the 
system displays the Eclipse version of the help. 

2. Edit the text displayed on the screen in one of the following ways: 

• Manually type the text you want to enter. 

• Upload a .txt file from your PC by using the hidden Alt-L for upload hot key and entering the 
DOS path to the file you want to upload. For example, enter c:/text/note.txt. Use forward 
slashes in the path name and be sure to include the .txt extension, or the upload will not work.  

• Copy and paste word processing text into the F9 help screen. For copying and pasting to work, 
from the Eterm menu bar select Configure, then select Communications, and then click the 
Enable Edit box. 

When typing, uploading, or pasting text, be aware that the F9 help screen does not have all the 
features of a word processor, nor does it work like a typical word processor. Adhere to the 
following guidelines: 

• Pressing Enter within a paragraph does not cause the following text to wrap to the next line. 

• Pressing Enter at the end of text does cause the cursor to wrap to the start of the next line. 

• The Tab key does not work. 

• The Backspace key does not delete text. 

• The Delete key works normally.  

• Bullets do not upload as bullets. 

• To move text to the next line, press the Insert key, place the cursor at the start of the text to 
be moved, and press the Spacebar until the text wraps. 

• To insert a blank line between paragraphs, press Alt-Insert. 

• To remove a blank line, place the cursor in the line and press Alt-Delete.  

• If you upload text into a Help Document Maintenance screen that contains existing text, the 
uploaded text will replace everything on the screen.  
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• When copying and pasting text with Eterm for Windows, you can paste new text at the end 
of the existing text. Just be sure to position the cursor correctly.  

3. Press Esc. 

The system displays the following prompt: Item changed. Update file? 

4. At the prompt, enter Y. 

The system saves the updated text as the User version of the help.  

Note: Regardless of whether you edited the User version or the Eclipse version of the 
help, the system saves your changes as the User version. 
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Viewing User-Defined F9 Help 
If you have created user-defined help for a field in the character-based system, the system displays this 
help when you press F9 in that field.  

To display user-defined F9 help: 

1. Position your cursor in the field for which you want to view the user-defined help and press F9. 

In the screen title, the asterisk (*) preceding and "User version" following the field ID indicate 
that you are viewing user-defined help.  

2. Use the Eclipse Version hot key to display the system help for this field. 

3. Use the User Version hot key to re-display the user-defined help. 
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Viewing User-Defined F11 Help in the Character-Based 
System 
When you display a screen and press F11 in the character-based system, the system displays the online 
help topic associated with that screen. Before you can display user-defined help topics assigned to a 
screen instead of the online help topic, you need to remove the pointer to the online help topic. 

Use the following procedures to remove a screen's pointer to the online help and view user-defined help 
assigned to the screen. You can also view user-defined F11 help topics from the Help menu. 

To remove a screen's pointer to the online help: 

1. From the screen for which you want to remove the pointer to the online help, press Shift-F11 to 
display the Help Topics Maintenance screen. 

Note: You must have Superuser authorization to use the Shift-F11 key. If prompted, log 
on to the character-based system. 

This screen lists the user-defined help topics assigned to this screen. 

2. Use the Web Help hot key to display the Address to Web Help screen. 

3. Delete the text displayed on this screen. 

4. Press Esc two times to exit both screens. 

To view user-defined F11 help from the screen to which it is attached: 

1. From the screen in the character-based system for which you want to view the user-defined help 
press F11 to display the help topics screen. 

The system lists the help topics assigned to the screen. 

2. Select the topic you want to view and press Enter. 

3. When finished reading the help topic, press Esc to exit the help topic and return to the screen. 

To view user-defined F11 help from the Help menu: 

1. From the System > System Files > Documentation menu, select Help Document Maintenance 
to display the Help Document Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. In the Keyword field, do one of the following: 

• Enter a keyword from the help topic title. 

• Enter a period followed by the document number assigned to the help topic. 

The system displays the help topic or a list of help topics that match your selection criteria. 

3. Select the topic to view and press Enter. 

4. When finished reading the help topic, press Esc to exit the help topic. 
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Creating and Editing User-Defined F11 Help in the Character-
Based System 
Pressing F11 on a screen in the character-based system accesses the online help system and displays a 
topic associated with that screen.  

You can also create custom F11 help topics for screens. For example, you can enter user-defined 
instructions that are specific to your company's operations. You can create new F11 help files by starting 
a new document and entering the text or by copying and editing an existing help document.  

After creating a user-defined help file, you need to assign it to a screen. 

Users must be assigned the HELP.F11.EDIT authorization key to create user-defined F11 help. 

Use the following tasks to: 

• Create user-defined F11 help. 

• Copy and edit user-defined F11 help. 

• Edit user-defined F11 help. 

• Assign user-defined F11 help to a screen. 

To create user-defined F11 help: 

1. From the System > System Files > Documentation menu, select Help Document Maintenance 
to display the Help Document Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. In the Keyword field, type the word new and press Enter. 

The system assigns a document number. 

3. In the Topic Heading field, enter a title for the help document. 

4. In the Keywords field, enter any keywords that can be used to search for the article using the 
Help screen. Keywords are not case sensitive. 

5. In the Text field, enter the text of your help document in one of the following ways:  

• Manually type the text you want to enter. 

• Upload a .txt file from your PC by using the Upload hot key and entering the DOS path to the 
file you want to upload. For example, enter c:/text/note.txt. Use forward slashes in the path 
name and be sure to include the .txt extension, or the upload will not work.  

• Copy and paste word processing text into the F11 help screen. For copying and pasting to 
work, on the Eterm menu bar select Configure, then select Communications, and then click 
the Enable Edit box. 

6. Note the help topic ID number and then press Esc to save the F11 help topic.  

To copy and edit user-defined F11 help: 

1. Display the document you want to copy in one of the following ways: 
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• From the System > System Files > Documentation menu, select Help Document 
Maintenance to display the Help Document Maintenance screen. In the Keyword field enter 
keywords to search for the document or enter a period (.) followed by the document ID. 

• From the screen to which the F11 help document is attached, press Shift-F11 to display the 
Help Topics Maintenance screen. Select the topic you want to copy and use the Edit 
Document hot key. 

Note: If prompted, log on to the character-based system. 

2. Use the Copy hot key. 

The system assigns a new ID number to the displayed document. 

3. Edit the Topic Heading, Keywords, and Text fields for the new document, as described in the 
task for creating F11 help. 

4. Note the help topic ID number and then press Esc to save the F11 help topic.  

To edit user-defined F11 help: 

1. Display the document you want to edit in one of the following ways: 

• From the System > System Files > Documentation menu, select Help Document 
Maintenance to display the Help Document Maintenance screen. In the Keyword field enter 
keywords to search for the document or enter a period (.) followed by the document ID. 

• From the screen to which the F11 help document is attached, press Shift-F11 to display the 
Help Topics Maintenance screen. Select the topic you want to edit and use the Edit Document 
hot key to display the document on the Help Document Maintenance screen. 

Note: If prompted, log on to the character-based system. 

2. When typing, uploading ,or pasting text, be aware that the F9 help screen does not have all the 
features of a word processor, nor does it work like a typical word processor. Adhere to the 
following guidelines: 

• Pressing Enter within a paragraph does not cause the following text to wrap to the next line. 

• Pressing Enter at the end of text does cause the cursor to wrap to the start of the next line. 

• The Tab key does not work. 

• The Backspace key does not delete text. 

• The Delete key works normally.  

• Bullets do not upload as bullets. 

• To move text to the next line, press the Insert key, place the cursor at the start of the text to be 
moved, and press the Spacebar until the text wraps. 

• To insert a blank line between paragraphs, press Alt-Insert. 

• To remove a blank line, place the cursor in the line and press Alt-Delete.  

• If you upload text into a Help Document Maintenance screen that contains existing text, the 
uploaded text will replace everything on the screen.  
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• When copying and pasting text with Eterm for Windows, you can paste new text at the end of 
the existing text. Just be sure to position the cursor correctly.  

3. Press Esc to save the F11 help topic. 

 To assign user-defined F11 help to a screen: 

1. Display the screen to which you want to assign a user-defined help document. 

2. Press Shift-F11 to display the Help Topics Maintenance screen. 

Note: If prompted, log on to the character-based system. 

3. On a blank line, type the title of your document and press Enter. 

Note: To insert a blank line, position the cursor on an occupied line and press Alt-Insert. 

4. In the Help Doc # field, type the number of the document you are assigning and press Esc. 

The system assigns your help document and returns you to the program screen. 
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Order Entry Views Maintenance Overview 
Order entry body screens display different columns of product information, depending on the selected 
order entry view. For example, one view shows unit and extended prices, and other views display product 
availability, shipping details, or backorder details. 

In addition to the standard views that come with the system, you can create custom views for specific job 
functions. For example, for those users who can adjust quotable prices but not vendor prices, you can 
create a view that displays only a quotable prices column or a view that shows both quotable and vendor 
prices but allows editing only in the quotable prices column. 

By assigning views to users, you can control the information they view and edit. Assign users OE views 
related to their job functions. To simplify the task of assigning views, you can create OE view templates, 
which contain groups of OE views. When you assign an OE view template to a user, the user has access 
to all of the views in the template. In addition to standard OE view templates that come with the system, 
you can create custom OE view templates. 

Both standard and custom OE views are version controlled. You must have SUPERUSER authorization 
to create custom views. You cannot edit views that are open to another user. Whenever you create or edit 
views, you must enter a tracker for the update. 
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Creating Custom OE Views 
Use the Order Entry View Maintenance window to create custom views for order entry body windows. 

Although you cannot edit standard views, you can copy and rename them. You can then edit the copied 
views to create custom views. You can also build custom views. If a custom view becomes obsolete, you 
can delete it. 

Order entry views use standard view elements and user-defined view elements. By default, the system 
assigns two required view elements to OE views: QUANTITY and PRODUCT.DESC. These elements 
must be included in all views to show item quantity and item descriptions on all orders. 

Once you have created custom views, you can assign them to users or use them to create custom OE view 
templates. 

Due to the nature of the Eclipse display, views for use in Eterm can only be 78 characters wide. You can 
however build views that are greater than 78 characters wide for use in Solar Eclipse. 

Use the following procedures to: 

• Create a custom order entry view. 

• Copy a view to create a custom order entry view. 

• Delete a custom order entry view. 

To create a custom order entry view: 

1. Display the Order Entry View Maintenance window in one of the following ways: 

• From the System > System Programming > User Defined Functions menu, select User 
Defined OE Views. 

• From the Tools > User Defined Documents menu, select User Defined OE Views. 

2. In the View ID field, enter or select New to display the following prompt: Enter New ID. 

3. At the prompt, enter an ID for the new order entry view and click OK. The ID can be up to 20 
characters.  

4. In the Mode field, select whether the view applies to sales, purchase, or transfer order entry. 

5. In the Description field, enter a description of the view, using up to 40 characters. 

This description displays in the list of available views on the order entry screens. 

6. To display the alternate product description when this view is used, select the Alternate 
Description option. Otherwise, the system displays the primary product description. 

7. By default, the system assigns two required view elements to all order entry views: QUANTITY 
and PRODUCT.DESC.  

• You can change the value in the Heading field for QUANTITY. For example, you can name it 
Item Quantity. 

• You can change the values in the Heading and Width fields for PRODUCT.DESC. 

8. In the Columns area of the window, select an order view element and click the Add button to add 
it to the view. 
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The system populates the Update Allowed, Multi-Lined, Override Allowed, Heading, Width, 
Decimal Places, Conversion, Justification, and Negative fields, based on the dictionary item 
definition.  

9. Edit the fields in the Column Options area of the window as needed, using the following 
guidelines: 

Field Guidelines for Editing 
Update 
Allowed 

Select this option if a user can update this field when using this view in order entry. 

Mulit-Lined Select this option if the column is multi-valued. 

Override 
Allowed 

Select this option to reserve one character of the column width for displaying an 
override asterisk (*). The designated view column displays an asterisk when 
overridden. Otherwise, override asterisks never display. 

Heading The column heading for this field. A column heading can only be as long as the field 
width. 

Width The width of the column in character spaces. Change the width as needed. As you build 
the view, the system tracks and displays the current view width in the Total Width 
field, including space for column separators. The total number of character spaces 
available for a view is 78. 
If the width is larger than 78, the Display In field in the status bar of the screen 
displays Solar. Any views that is 78 characters or less can be viewed in both Eterm and 
Solar Eclipse environments. 

Conversion The pick output conversion code, which determines the display or report format of the 
data, if the data in this column is numerical. 

Decimal 
Places 

The number of decimal places to display, if the field is numeric. 

Justification Enter R or L to change the justification of the data in the column to the right or left. 
Right justify dates and numbers. 

Negative Select this option to allow negative numbers. You can only select this option for right 
justified fields. 

10. Repeat steps 7 and 8 to add additional dictionary items to the view. 

11. Save the view and exit the window. 

To copy a view to create a custom order entry view: 

1. Display the Order Entry View Maintenance window in one of the following ways: 

• From the System > System Programming > User Defined Functions menu, select User 
Defined OE Views. 

• From the Tools > User Defined Documents menu, select User Defined OE Views. 

2. In the View ID field, select or enter the ID of the view to copy. 

3. From the File menu, select Copy. 

4. At the prompt, enter the ID of the new view. 

The dictionary items from the copied view populate the window for the new ID. 

5. Edit the new view as needed.  
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6. Save the view and exit the window. 

To delete a custom order entry view: 

1. Display the User Defined Order Entry Views window in one of the following ways: 

• From the System > System Programming > User Defined Functions menu, select User 
Defined OE Views. 

• From the Tools > User Defined Documents menu, select User Defined OE Views. 

2. In the View ID field, select the view to delete. 

3. From the File menu, select Delete.  

The system displays the following prompt: Are you sure you want to delete this from all user 
profiles? 

4. At the prompt, select Yes. 
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Editing Custom OE Views 
Edit a custom order entry view when you need to change the data or format of the data displayed in the 
view. 

Custom order entry views are version-controlled. After you update a view, the system opens the view 
record to your user ID. You can then accept, revise, or undo your changes. Once you are satisfied with the 
changes you made, close the view record. The system maintains a log of each new version of the view 
and who made the changes. 

To edit a custom OE view: 

1. Display the Order Entry View Maintenance window in one of the following ways: 

• From the System > System Programming > User Defined Functions menu, select User 
Defined OE Views. 

• From the Tools > User Defined Documents menu, select User Defined OE Views. 

2. In the View ID field, enter the ID of the order entry view to edit.  

3. Edit the view elements as needed.  

See Creating Custom OE Views for field descriptions. 

4. Save the updated view and exit the window. 

The system displays the Program Change Log Entry window, which shows the name of the file 
and view updated, along with your user ID, the current date and time, and the view's version 
number incremented by one.   

5. Complete the window as follows: 

• In the Comment field, enter a comment describing the changes you made. 

• In the Activity Log # field, enter the number of the tracker that prompted the change.  
If necessary, press Shift-F4 and create a tracker assigned to your user ID. 

• Exit this window and return to the User Defined Order Entry Views window. 

Though not displayed, the updated order entry view is now open to your user ID. Other users can 
view the record, but they cannot edit the record until you close it.  

6. Display the updated order entry view record again.  

The window shows that it is open to your user ID and displays the new version number followed 
by a modification number. Each time you modify the view while it is open to your user ID, the 
system increments the modification number. 

7. Do one of the following: 

• Make additional changes to the displayed record. Save the record and then return to step 6. 
 
The system displays a blank Order Entry View Maintenance window; it does not display the 
Program Change Log Entry window again. When you display the updated view again, note that 
the modification number following the version number is incremented by one. This indicates 
the number of modifications you have made to this view while it has been open to your user 
ID. 
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• If you are satisfied and finished with the changes you made, click Close.  
 
The system releases the displayed view from its open status and makes an entry in the change 
log for this new version of the view. 

• If you are not satisfied with the changes you made, click Undo. Then return to step 6. 

• If the new version contains just one modification, the system displays a prompt similar to the 
following: 

Undo Ver # 14 for OE.VIEWS~BBGUN1 (Y/N) : N 

Select Yes to undo the changes you made in the new version or select No to exit the prompt. 

• If the new version contains more than one modification, the system displays a prompt similar 
to the following: 

Undo OE.VIEWS~BBGUN1 - Ver#14/Mod#14[2]/Nothing ? (V/M/N) : N 

Select Version to undo all of the changes in the new version, select Modification to undo 
only the most recent modification in the new version, or select None to exit the prompt. 
When you undo a complete version, the view record is no longer open to your user ID. 
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Editing Order Entry View Templates 
You can edit order entry (OE) view templates to make them match an individual's job functions. 

For example, if an employee who is responsible for entering and checking on orders does not need the 
Audit Pricing view for sales order entry, you can edit the *SOE.ALL template to remove the Audit 
Pricing view for this employee.  

Standard OE view templates are not editable. To create your own templates for groups of employees, 
copy and rename a standard OE view template and then edit it. 

To edit OE view templates: 

1. From the System > System Files > User Control menu, select User Maintenance to display the 
User Maintenance window. 

2. In the User ID field, enter a user's ID to display the corresponding record. 

3. From the Maintenance menu, select Order Entry Views to display the Order Entry View 
Selection window, which lists the views and templates assigned to this user. The system indicates 
template IDs with a check mark in the Template column. 

Note: You must be assigned the USER.VIEW.SELECT authorization key to access this 
window. 

4. Select the template to edit. 

The system displays the views assigned to the template in the Template area of the window. 

5. Do any of the following to edit the template: 

• To add a view to the template, position the cursor on a blank line in the View column of the 
Template area and select a view from the list. The system displays the ID and description. 
Check the order types to which the view applies. 

• To remove a view from the template, select the view and press Alt+Delete. 

• To change the template description, select Change Description from the Template menu. At 
the prompt, enter the new template description. 

• To delete a template, position the cursor on the ID and then select Delete from the Template 
menu. The system prompts you to confirm the deletion. 

6. To designate an order entry view as the default for an order type, select one of the following order 
types in the Default field. When the user enters the selected order type, this is the default view. 
This field applies only to views. 

• NDOE - New Direct OE 

• NSOE - New Sales OE 

• IDOE - Invoiced Direct OE 

• ISOE - Invoiced Sales OE  

• ODOE - Open Direct OE 

• OSOE - Open Sales OE 
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7. Click OK to save this information and return to the User Maintenance window. 

Note: A user to whom you have assigned a new view must log off the system and then 
log back on before being able to use the view. 
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Creating Custom OE View Templates 
An OE view template contains order entry views that have been grouped together by function. For 
example, the purchase order entry template contains order entry views for purchase orders, stock receipts, 
and purchasing inquiries. When you assign templates to users, they have access to all of the views in the 
templates. You can use standard templates or create custom templates. 

Although you cannot edit standard OE view templates, you can copy and rename them. You can then edit 
the copied templates to create custom templates for groups of employees who need specific order entry 
information. 

You can add custom OE views that are wider than 78 characters to a template for users who use Eterm, 
Solar Eclipse, or both. The users OE view selection list in Eterm includes only the views that are 78 
characters or less. However, if the user is in Solar Eclipse, the user can select a view that is wider than 78 
characters. 

Use the following procedures to: 

• Create a custom OE view template. 

• Copy a template to create a custom OE view template. 

To create a custom OE view template: 

1. Display the Order Entry View Maintenance window in one of the following ways: 

• From the System > System Programming > User Defined Functions menu, select User 
Defined OE Views. 

• From the Tools > User Defined Documents menu, select User Defined OE Views. 

2. From the Edit menu, select Template to display the Select a Template list. 

3. Select New to display the New Order Entry View Template dialog box. 

4. At the New Template ID prompt, enter the new template ID. The ID can be up to 20 characters 
long. 

5. At the Template Description prompt, enter a description of the template. The description can be 
up to 30 characters long. 

The Order Entry View Template window displays. 

6. To add a view to the template, in the View Element column, select a view to add.  

Note: To delete a view, select the view and from the File menu, select Delete. 

7. To designate an order entry view as the default for a new, open, or invoiced sales or direct order, 
in the Default column, select the default type of order for the designated view. 

8. Save the template and exit the window. 

Once created, user-defined order entry templates are available for use. 

To copy a template to create a custom OE view template: 

1. Display the Order Entry View Maintenance window in one of the following ways: 

• From the System > System Programming > User Defined Functions menu, select User 
Defined OE Views. 
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• From the Tools > User Defined Documents menu, select User Defined OE Views. 

2. From the File menu, select Template and select the template to copy.  

The Order Entry View Template window for the selected template displays. 

3. From the File menu, select Copy. 

4. At the Enter New ID prompt, enter the ID of the new template to create. 

The system creates a template with the new ID and the Defined Order Entry Views window 
displays. This window is blank. 

5. In the View ID field, enter the new template name to display the Order Entry View Template 
window for the new template. 

The system populates the window with the views from the copied template. 

6. In the Template Description field, edit the copied description as needed. 

7. Do any of the following to edit the views assigned to the template: 

• To remove an entry from the template, press Alt-Delete. 

• To insert a blank line, press Alt-Insert.  

• To add a view to the template, in the View Element column, select a view to add. 

8. Save the new template and exit the window. 
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Assigning Order Entry Views and Templates to Users 
The sales, purchase, and transfer order entry Body screens display different columns of information, 
depending on the selected view. Views can show information such as unit or extended prices, product 
availability, shipping, or backorder details.  

OE view templates contain order entry views grouped together by function. For example, *POE.ALL 
contains all purchase order entry views. View IDs prefixed with an asterisk are OE view templates. 

Because not all views are appropriate for all users, assign each user the order entry views related to their 
job function. 

To assign order entry views and templates to a user: 

1. From the Maintenance menu, select Order Entry Views to display the Order Entry View 
Selection window, which lists the views and templates assigned to this user.  

Note: You must be assigned the USER.VIEW.SELECT authorization key to access this 
window. 

2. To assign a view or template, position the cursor in a blank line in the View column of the View 
area, and select a view or template from the list. Template IDs display at the top of the list with a 
check mark in the Template box. 

The system displays the view or template ID, along with a check mark for the order type to which 
the view applies, in the Order Entry View Selection window.  

If you select a template, the system displays the views assigned to that template in the Template 
area of the window. 

3. You can edit the views assigned to a template, as needed. 

4. To designate an order entry view as the default for an order type, select one of the following order 
types in the Default field. When the user enters the selected order type, this is the default view. 
This field applies only to views. 

• NDOE - New Direct OE 

• NSOE - New Sales OE 

• IDOE - Invoiced Direct OE 

• ISOE - Invoiced Sales OE  

• ODOE - Open Direct OE 

• OSOE - Open Sales OE 

5. Repeat steps 2 through 4 to add additional views or templates to the user's profile. 

6. Click OK to save this information and return to the User Maintenance window. 

Note: A user to whom you have assigned a new view must log off the system and then 
log back on before being able to use the view. 
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Creating Order Entry View Elements 
Order entry view elements define the contents of the columns displayed in order entry views. The system 
includes pre-defined order entry view elements used in the standard Eclipse views. Only installers and 
designated client personnel should use the Order Entry View Element Maintenance window to define 
additional view elements to use in custom order entry views. 

You can create the following two types of order entry view elements: 

• Dictionary item 

• Custom 

Note: Only Eclipse programmers should create custom order entry view elements. 

To use a dictionary item as an order entry view element: 

1. From the Tools menu, select Order View Element Maint to display the Order Entry View 
Element Maintenance window. 

2. In the View Element ID field, enter an identifier for the view element. 

Note: To display an existing element, press F10 and select the element from the list. 

3. Flag the Dictionary Information Only check box. 

4. In the From File field, select the file in which the dictionary item is located. 

5. In the Dictionary ID field, select the dictionary item. 

6. In the Dictionary Key field, select the order element to use as the key to access this dictionary 
item. 

7. Save the record and exit the window. 

Note: When you assign a dictionary item to an order entry view element, you do not need 
to complete any other fields on this window. The system uses the display and 
update information defined for the dictionary item in Dictionary Maintenance. 

To create a custom order view element: 

1. From the Tools menu, select Order View Element Maint to display the Order Entry View 
Element Maintenance window. 

2. Complete the fields in the Non-Dictionary Information area of the screen. 

Field Description 
Description Enter the description to display as the default column heading for this element. 

Verification Enter the subroutine to use to validate data entered for this element, if 
necessary. 

Conversion Enter the pick output conversion code, which determines the display or report 
format of the data stored in this element. 

Decimal Places Enter the number of decimal places to display, if this element is numeric. 

Justification Enter R or L to specify the justification of the data in the column as right or 
left. Right justify dates and numbers. 
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Field Description 
Allow Negative Indicate whether to allow negative numbers. You can only allow negative 

numbers for right justified fields. 
• Y - Allows negative numbers. 
• N - Does not allow negative numbers. 

Blank View Indicate whether the view element displays data in the view. The default is N. 
• Y - The view element does not display data in the column of the view to 

which you assign it. The system populates the display Subroutine field with 
the OE.VE.DISP.BLANK subroutine. 

• N - The view element displays data in the column of the view to which you 
assign it. 

Multi-line Indicate whether this element displays on multiple lines. 

Override Flag Indicate whether to reserve one character of the column width for displaying an 
override character. 
• Y - One character of the column width is reserved for displaying an override 

character. 
• N - Override characters never display. 

Show For 
Comments 

Indicate whether to display the contents of this view element on comment lines 
in the order. 
• Y - Displays for order line items and comment lines. 
• N - Displays for order line items only. 

3. Complete the fields in the Display Information area of the screen. 

Field Description 
Subroutine Identify the subroutine that calculates the display information for the view 

element. 

Parameter If the subroutine performs multiple functions, enter the modifier used to select 
the function that will display this view element. 

4. Complete the fields in the Update Information area of the screen. 

Field Description 
Subroutine Identify a subroutine to be used to process the data entered from a screen to 

update the view element. 

Parameter If the subroutine performs multiple functions, enter the modifier used to select 
the function that will update this view element. 

Edit Paid Direct Indicate whether this element is editable on the sales order portion when the 
purchase order portion of a direct order has been paid. 
Y - Editable. 
N - View-only. 

5. Save the record and exit the window. 
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Editing Order Entry View Elements 
Edit a custom order entry view when you need to change the data or format of the data displayed in the 
view. 

Custom order entry views are version-controlled. After you update a view, the system opens the view 
record to your user ID. You can then accept, revise, or undo your changes. Once you are satisfied with the 
changes you made, close the view record. The system maintains a log of each new version of the view 
and who made the changes. 

To edit an order entry view element: 

1. From the Tools menu, select Order View Element Maint to display the Order Entry View 
Element Maintenance window. 

2. In the View Element ID field, enter the ID of the view element to edit.  

3. Edit the view elements as needed.  

See Creating Order Entry View Elements for field descriptions. 

4. Save the updated element and exit the window. 

The system displays the Program Change Log Entry window, which shows the name of the file 
and view updated, along with your user ID, the current date and time, and the view's version 
number incremented by one.   

5. Complete the window as follows: 

• In the Comment field, enter a comment describing the changes you made. 

• In the Activity Log # field, enter the number of the tracker that prompted the change.  
If necessary, press Shift-F4 and create a tracker assigned to your user ID. 

• Exit this window and return to the User Defined Order Entry Views window. 

Though not displayed, the updated order entry view is now open to your user ID. Other users can 
view the record, but they cannot edit the record until you close it.  

6. Display the updated order entry view record again.  

The window shows that it is open to your user ID and displays the new version number followed 
by a modification number. Each time you modify the view while it is open to your user ID, the 
system increments the modification number. 

7. Do one of the following: 

• Make additional changes to the displayed record. Save the record and then return to step 6. 
 
The system displays a blank Order Entry View Maintenance window; it does not display the 
Program Change Log Entry window again. When you display the updated view again, note that 
the modification number following the version number is incremented by one. This indicates 
the number of modifications you have made to this view while it has been open to your user 
ID. 

• If you are satisfied and finished with the changes you made, click Close.  
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The system releases the displayed view from its open status and makes an entry in the change 
log for this new version of the view. 

• If you are not satisfied with the changes you made, click Undo. Then return to step 6. 

• If the new version contains just one modification, the system displays a prompt similar to the 
following: 

Undo Ver # 14 for OE.VIEWS~BBGUN1 (Y/N) : N 

Select Yes to undo the changes you made in the new version or select No to exit the prompt. 

• If the new version contains more than one modification, the system displays a prompt similar 
to the following: 

Undo OE.VIEWS~BBGUN1 - Ver#14/Mod#14[2]/Nothing ? (V/M/N) : N 

Select Version to undo all of the changes in the new version, select Modification to undo 
only the most recent modification in the new version, or select None to exit the prompt. 
When you undo a complete version, the view record is no longer open to your user ID. 
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Customer and Vendor Standard Notes Overview 
Use customer and vendor standard notes to create company-wide shipping instructions, such as "Call job 
site before scheduling delivery or material will be refused," or company-wide internal notes, such as 
"Check recent price updates." 

Order writers can attach these notes to an order to ensure that all transaction requirements are met.  

For example, a customer requires a call to schedule delivery of product. Attach the standard shipping note 
"Call job site before scheduling delivery or material will be refused" to the customer's sales order. The 
shipping ticket for that customer displays the note. The note reminds the person in charge of delivery of 
the customer's requirements.  
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Creating and Editing Customer and Vendor Standard Notes 
Use the Customer/Vendor Standard Notes program to create and edit company-wide notes to apply to 
orders. You can create the following types of notes: 

• Customer Standard Shipping Instructions 

• Customer Standard Internal Notes 

• Vendor Standard Shipping Instructions 

• Vendor Standard Internal Notes 

Create these notes as reminders of transaction requirements. Order writers can then use the Notes or 
Shipping Instructions hot keys to attach these notes to orders from the order's Header screen. 

Use the following procedures to: 

• Create customer or vendor standard notes. 

• Edit customer or vendor standard notes. 

To create a new customer or vendor standard note: 

1. From the System > System Files > Customer/Vendor Control > Customer/Vendor Standard 
Notes menu, select the type of note to create. 

Note: If prompted, log on to the character-based system. 

The system displays a screen listing all the note titles currently defined for that type. 

2. Select ** NEW NOTE ** and press Enter to display the Note Title screen. 

3. Enter a title for the note and press Esc to display the screen for that note title. 

4. Enter the text of the note and press Esc. 

5. Press Esc to return to the Customer/Vendor Standard Notes menu. 

To edit a customer or vendor standard note: 

1. From the System > System Files > Customer/Vendor Control > Customer/Vendor Standard 
Notes menu, select the type of note to edit. 

Note: If prompted, log on to the character-based system. 

The system displays a screen listing all the note titles currently defined for that type. 

2. Position the cursor on the note to edit and press Enter to display the screen for the selected note 
title. 

3. Edit the note as follows: 

• To change the text, type over the existing text or add text to the end of the note. Press Esc to 
save your changes. 

• To change the title, use the Edit Title hot key. Type over the existing title and press Esc to 
save your changes. 
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• To delete the note, use the Delete Note hot key. Enter Y at the prompt to confirm your 
deletion. 

4. Press Esc to return to the Customer/Vendor Standard Notes menu. 
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Business Closed Days Overview 
Use the Business Closed Days Maintenance program to create a list of dates when your business is 
closed. The system uses this list when calculating a product's availability date.  

Create the business closed days list as far as you want into the future. These days do not affect the plenty 
date calculation. 

Creating a List of Closed Days 
When creating a list of closed days, we recommend that you: 

• First, create a list of all special days that your business is closed, for example, holidays or a day 
when your business is closed for inventory. Enter these days in the Business Closed Day screen, 
chronologically. 

• Then, use the Date Scheduler screen to add the days of the week that your business is normally 
closed, for example, Saturday and Sunday. The system creates a list of all of the closed days and 
places the special days in the proper sequence. 

If you reverse this process, you must advance through the list and insert each special closed day in the 
proper sequence. 

Editing a List of Business Closed Days 
You can add new dates to the business closed days list at any time. The system requires that you add the 
date in the proper sequence on a blank line. You can type over a date provided the revised date is still in 
the proper sequence. Otherwise, you need to delete the old date and then add the revised date in the 
appropriate location.  

For example, you set up New Year's Day and the day after as closed days and then decide to change the 
closed days to New Year's Day and the day before. To do this, delete the entry for January 2nd and then 
insert a new line before January 1st and create an entry for December 31st. 
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Identifying Business Closed Days 
Use the Business Closed Days screen and Date Scheduler screen to create a list of all special days, such as 
holidays, and normal days, such as Saturday and Sunday, that your business is closed.  

After creating a list, you can also edit it as necessary, on the Business Closed Days screen and Date 
Scheduler screen. 

Use the following procedures to: 

• Create a list of business closed days. 

• Edit a list of business closed days. 

To create a list of business closed days: 

1. From the System > System Files menu, select Business Closed Days Maintenance to display 
the Business Closed Days screen. 

Note: If prompted, log on to the character-based system. 

2. On a blank line in the Date column, enter the first date from your list of special closed days. The 
system populates the Day field with the corresponding day of the week. 

3. Enter the remaining special closed dates, as described in the previous step, in chronological order. 

4. Use the Add hot key to display the Date Scheduler screen. 

5. Enter the Starting Date and Ending Date to designate the time period. 

6. Next to the days that your business is normally closed, enter an asterisk (*). 

For example, if your company is closed on weekends, enter asterisks next to Saturday and 
Sunday. If it is closed only on Sunday, just flag Sunday. 

7. Flag the Weekly field by entering an asterisk (*) next to the field.  

Note: The Daily and Bi-Weekly fields are not typically used with the Business Closed 
Days screen. 

8. Press Esc to save the schedule and return to the previous screen. 

The system adds the designated closed days to the schedule. 

9. Press Esc to save the Business Closed Days schedule. 

To edit a list of business closed days: 

1. From the System > System Files menu, select Business Closed Days Maintenance to display 
the Business Closed Days screen. 

Note: If prompted, log on to the character-based system. 

2. To add a date to the list, do the following: 

• Position the cursor on the date that follows the date to enter. For example, to insert a date 
between 01/01/04 and 5/24/04, position the cursor on 05/24/04. 

• Press Alt-Insert. 
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• Type the date. 

• Press Enter to add the date to the list.  

Note: If you add a date to an existing list and do not insert a blank line at the cursor 
position, the date you enter replaces the date at the cursor. If the date you enter is 
out of sequence in the list, a message notifies you that the date must fall between 
the date above and the date below the cursor.  

3. To delete a date, position the cursor on the date and press Alt-Delete. 

4. To clear all dates from the list, use the Clear hot key. 

5. Press Esc to save your changes. 



Solar Eclipse Application Maintenance Rel. 8.7.4 

114 © 2012  Epicor Software Corporation. All rights reserved. 

Area Code Updating Overview 
Use the Area Code Updating program to keep area codes current in the system.  

If, for example, in Colorado, Denver and Colorado Springs share the same area code, and the state assigns 
a new area code to the Colorado Springs region, you can use this program to change the area code for all 
of the affected telephone numbers at once. 

When you update area codes, select whether to change the area codes for entities (customer or vendor 
businesses) or contacts (customer or vendor personnel within individual companies). Then specify all the 
exchanges within the old area code that need to be updated to the new area code. The exchange is the 
middle part of the phone number. For the phone number 720-555-8742, 555 is the exchange. 
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Changing Telephone Area Codes 
Use the Area Code Updating screen to change area codes for selected entities and contacts in your 
company. 

To change telephone area codes: 

1. From the System > System Files >Customer/Vendor Control menu, select Area Code 
Updating to display the Area Code Updating screen. 

Note: If prompted, log on to the character-based system. 

2. In the Update field, press F10 and select whether to update telephone numbers in the Entity file, 
Contact file, or both. 

3. In the Old Area Code field, enter the area code to change.  

Note: To change multiple old area codes, use the Multi Old AC hot key. When you 
specify multiple area codes, *Multi* displays in the field. 

4. In the New Area Code field, enter the new area code. 

5. In the State field, enter the abbreviation of the state to which these area codes apply. 

6. In the Affected Exchanges field, enter the three-digit exchanges for which to change the area 
code.  

The exchange is the middle part of the phone number. For example, in the phone number 720-
555-8742, 555 is the exchange. 

For each exchange, position the cursor on a blank line and type the three-digit number. 

7. Use the Begin hot key to process the area code change. 

8. To change the area code for other exchanges, repeat the previous steps. 

• Use the Change New AC hot key to change the value in the New Area Code field. 

• Use the Clear Exchanges hot key to clear the list of exchanges. 

9. Press Esc to save the changes and exit the screen. 
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Message Sounds Maintenance Overview 
In User Maintenance you can assign a musical sound to alert the designated user of incoming messages, 
job queue entries, or the completion of spooler activity. You can supplement the standard sounds 
provided with the system by adding new .wav files containing other message sounds. 
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Maintaining Message Sounds 
Use the Message Sounds Maintenance to add and delete tunes to alert users to messages.  

To maintain message sounds: 

1. From the System > System Files > User Control menu, select Music Composer to display the 
Message Sounds Maintenance window. 

2. To add a sound, do the following: 

• From the File menu, select Add Sound to display the Save window. 

• In the Save in field, search your directories and select the .wav file to add as a new message 
sound. 

• Click the Save button to display the Message Sounds Maintenance prompt. 

• Change the name displayed in the Enter name field, if needed. 

• Click OK to add the name to the list on the Message Sounds Maintenance window. 

3. To play a sound, do the following: 

• Position the cursor on the sound to play. 

• From the File menu, select Play to play the sound. 

4. To delete a sound, do the following: 

• Position the cursor on the sound to delete. 

• From the File menu, select Delete Sound. 

5. Save the changes and exit the window. 
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